How to removed hsLang=en from a page url?

Highlighted
Regular Contributor

Hi All,

Would like to ask for assistance, is there a way to remove the hsLang=en from a page url? 
I've checked the "Enable Language Specific Redirects" from the setting > Domains & URLs > Language Setting and it is disabled but the hsLang=en still shows in the domain url in one of our web pages.


Thank you,
Julie Costales

Reply
0 Upvotes
3 Replies 3
Community Manager

Hi @costalesja11,

 

Are you still experiencing this issue? Can you confirm the issue occurs across multiple browsers, after clearing your cache and through an incognito window? 

 

I also wanted to share this resource which discusses managing multi-language content.

 

Thank you,

Jenny


Did my post help answer your query? Help the Community by marking it as a solution
Reply
0 Upvotes
Regular Contributor

Hi @jennysowyrda,

Actually Im not sure how to navigate to that URL, it happens that it shows in the list of page that we are having h1 duplicates in the Screaming Frog for SEO, and it happens for only one page. As for the given details from this document, there is no multi language setup or configuration done for the said page that is having issue, that is why I am not sure how did it happen or how it was set up.

Thank you

Reply
0 Upvotes
New Contributor

I'm having the same issue in SEM Rush.  I added URL Parameters in SEM Rush and in Google Search Console to ignore the hsLang parameter, but I want to understand why these pages are being created and how to remove them.

Reply
0 Upvotes