How to autoplay vidyard video in a blog page?

Highlighted
Regular Contributor

Hi All,

I would like to ask for assistance if someone can help me how to autoplay videos from a blog page?

As per hubspot documentation, the videos inserted from rich text block in a blog page were rendered by a Vidyard video player and there is no parameter available for autoplay.
https://designers.hubspot.com/docs/hubl/hubl-supported-tags

Was autoplay not possible in videos inserted from rich text block in blog pages?

Thank you in advance.

 

Reply
0 Upvotes
6 Replies
Regular Contributor

I'm having the same concern. I'll keep looking and keep this post updated if I find an answer

Reply
0 Upvotes
Regular Contributor

Here's the answer from HS Support:

 

It is currently not possible to pass that value into the video right now, but the tool is still getting features added so that is something we'll be adding in the future. As a workaround, you could embed the video from youtube or another hosting site using their generated embed code and pass the muted and autoplay attributes to the code, which would allow it to be autoplayed.

 

Reply
0 Upvotes
Regular Contributor

Hi @louischausse,

 

Apologies for the late response, but this was already addressed in the below link. Thank you for your inputs.

https://community.hubspot.com/t5/Blog-Website-Page-Publishing/How-to-add-autoplay-to-vidyard-videos-...

Best Regards,
Julie Costales

Reply
0 Upvotes
Regular Contributor

Thank you for this solution!

 

However, I still have a problem with videos embedded in a  modal.

 

They are triggered at page load and they play in the background...

 

I would like them to be triggered when the button is clicked...

 

Here's an example page:

 

https://solutions.jlr.ca/en/features

 

thank you

Reply
0 Upvotes
Regular Contributor
 
Reply
0 Upvotes
Regular Contributor

Thank you @costalesja11

 

But I don't understand how we could set up the code to trigger autoplayif we can't use parameters in the video embed code such as:

 

autoplay="autoplay"

autoplay="true"

autoplay="1"

 

 

Reply
0 Upvotes