How do I get my YouTube video to autoplay when my page loads?

kdmeg
HubSpot Employee

Grab the embed code from the YouTube video to be added to your page:

<iframe width="560" height="315" src="http://www.youtube.com/embed/evL5jaZx8vk" frameborder="0" allowfullscreen></iframe>

Add "?rel=0&autoplay=1" after the URL in the embed code src:

<iframe width="560" height="315" src="http://www.youtube.com/embed/evL5jaZx8vk?rel=0&autoplay=1" frameborder="0" allowfullscreen></iframe>

0 Upvotes
6 Replies 6
ecamu
Member

This used to work beautifully but now it doesn't. Not on older landing pages or new one I make. Any ideas on what's wrong? Are there some new settings in Hubspot somewhere? I created a webpage on my website and used the same embed code and it worked perfectly.  But on Hubspot landing pages it will not autoplay. Help is greatly appreciated!

0 Upvotes
ecamu
Member

Ok - after some research and troubleshooting - I've discovered that Google has changed their autoplay policy in Chrome to "improve the user experience."  

 

https://developers.google.com/web/updates/2017/09/autoplay-policy-changes 

 

I don't like it. But  at least it still autoplays in Firefox and Edge/IE.

toriworks
Participant

How does this work though when using the Video module? (not an embed code)

0 Upvotes
KKnowles
Member

Old thread but still relevant as I hit this issue today. If you set &mute=1 in your embed code, autoplay will work as expected.

sidneyhaitoff
Participant

Only on desktop, but it's not working for me on mobile for some reason.

0 Upvotes
sidneyhaitoff
Participant

And there's no option to unmute from mobile when the mute code is added to the embed code.

0 Upvotes