Forced formatting on custom coded blog template

New Contributor

Hi, I'm facing an issue where css is pushed onto our custom coded blog template by the HubSpot platform.

 

I run every blog post via the TextEdit tool on OS to get rid of all formatting before pasting the content onto HubSpot, but for some reason random css ends up in the code and messes up the formatting I've done on HubSpot editor and then I end up going through and cleaning up the code manually, which is annoying and time consuming.

 

The issue in more detail

 

If I copy-paste text from a section to another when editing in Inline Mode, for some reason <span>copy-pasted text</span> appears to the pasted text. If I then try select a section of that copy pasted text which is inside the paragraph and try to style it as a heading, the whole <p>copy-pasted text</p> gets formatted as a heading.

 

I usually select the heading style from navigation — headings, and then it sometimes happens that the text styled as heading appears without the end tag (for example: </h4>) which means that everything after gets styled as a heading, which then messes up everything else I try to style later on.

 

I've contacted your customer support but weren't able to help. 

 

Patricia

Reply
0 Upvotes
3 Replies 3
Esteemed Contributor | Gold Partner

Hi Patricia!

 

- So you mean, when you copy & paste text from a document into a Hubspot blog area?

 

- Have you tried to copy the text, paste it into a textdocument & flatten the text to remove all formatting? (on mac: Textedit - paste text and then Format > Make Plain Text)

Reply
0 Upvotes
Highlighted
New Contributor

Hi, 

 

Yes, as I stated in my first message: I run every blog post via the TextEdit tool on OS to get rid of all formatting before pasting the content onto HubSpot.

 

So it happens when I copy-paste content from TextEdit to HubSpot but also if I copy-paste a section from one location to another within the blog post I'm editing. 

 

Patricia

 

 

Reply
0 Upvotes
Esteemed Contributor | Gold Partner

Weird.

 

When pasting, have you tried pasting it into the HTML editor by clicking </> ? When pasting it should have no formatting at all.

 

And after formatting as you wish?

Reply
0 Upvotes