Wussten Sie, dass wir eine deutschsprachige Community haben?

Centering a Rich Text module on mobile

lösung
Stratege

Good morning Smiley (fröhlich)

 

I'm having an issue with the first Rich Text module on this page.

 

While it is centered perfectly on desktop, the bottom line of text aligns to the left regardless of the styling i have put on it. Below are images of how it displays on desktop and mobile.

 

Any help would be greatly appreciated.

 

Desktop.PNGDesktopMobile.PNGMobile

Antworten
0 Like / Likes
Akzeptierte Lösung / Akzeptierte Lösungen

Akzeptierte Lösungen
Sachkundiger

Hello @Jlawal
        i have checked the page it has problem with the inline blank spacing. if you are aware with html  then it would be better to remove them from richtext. but if you are not aware with html coding then its fine just open page editor go to settings > Advanced Options > Head HTML and paste below code in head HTML and you will get the content centered.

<style>
#hs_cos_wrapper_module_1512569875826154 hr + span { display: block; }
#hs_cos_wrapper_module_1512569875826154 hr + span span { display:inline-block; text-indent:-120px; }
</style>



Please mark this as solution if it helps !

5 ANTWORTEN 5
Sachkundiger

"md-tc" put this on the CSS class feild in the design manager selecting the text module.

Highlighted
Hubspot-Mitarbeiter

Hey @Jlawal!

I went ahead and checked out the mobile code. 

It seems that text-align:left is applied to the class called "page-banner-overlay". 

css.pngcss

This way you can center align those text for desktop and mobile. 

It seems that you have multiple spaces in front of "never", so I would recommend you to remove it from page editor. 

 

Stratege

Neither of those seem to be working for me unfortunately Smiley (traurig) @Shaykoo @Yoshi

Antworten
0 Like / Likes
Sachkundiger

Hello @Jlawal
        i have checked the page it has problem with the inline blank spacing. if you are aware with html  then it would be better to remove them from richtext. but if you are not aware with html coding then its fine just open page editor go to settings > Advanced Options > Head HTML and paste below code in head HTML and you will get the content centered.

<style>
#hs_cos_wrapper_module_1512569875826154 hr + span { display: block; }
#hs_cos_wrapper_module_1512569875826154 hr + span span { display:inline-block; text-indent:-120px; }
</style>



Please mark this as solution if it helps !

Stratege

Thank you @Designer_WOT, that has worked perfectly Smiley (fröhlich)

Antworten
0 Like / Likes