CTA load slow

SOLVE
giliard
Member

I want to know how I fix a CTA that appears slow after the page fully loads.

 

I recorded with a GIF, see bellow:

GP.gif

 

Notice the CTA appears seconds after the page load

0 Upvotes
1 Accepted solution

Accepted Solutions
stefen
Solution
Key Advisor | Partner

@giliard because of all the tracking information being collected on those, they don't get loaded on the page until the javascript can be evaluated and executed. They will always be inherently slower than a static link. As a compromise, you could instead generate a tracking link inside HubSpot and use that instead. This way you can still track clicks and have a performant button. More info on HubSpot tracking links: https://knowledge.hubspot.com/settings/how-do-i-create-a-tracking-url

Stefen Phelps, Community Champion, Kelp Web Developer

View solution in original post

3 Replies 3
PamCotton
Community Manager

Hello @giliard 

 

Thank you for sharing this GIF, I tested in my end and I was unable to reproduce this behavior, my recommendation would be clear your browser cache 

Also is this behavior repeating in other browsers? Mobile?

 

Let us know how that works.

 

Stay Safe,

 

Pam

Você sabia que a Comunidade está disponível em outros idiomas?
Participe de conversas regionais, alterando suas configurações de idioma !


Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !


0 Upvotes
stefen
Solution
Key Advisor | Partner

@giliard because of all the tracking information being collected on those, they don't get loaded on the page until the javascript can be evaluated and executed. They will always be inherently slower than a static link. As a compromise, you could instead generate a tracking link inside HubSpot and use that instead. This way you can still track clicks and have a performant button. More info on HubSpot tracking links: https://knowledge.hubspot.com/settings/how-do-i-create-a-tracking-url

Stefen Phelps, Community Champion, Kelp Web Developer

View solution in original post

giliard
Member

Thank you both.

 

I think the @stefen answer explains why this happens.