CMS Development

sst
Member

CMS CLI upload error

SOLVE

Anyone get these errors when running hs upload or hs watch?

 

[ERROR] Uploading file "/home/me/mytheme/fields.json" to "mytheme/fields.json" failed
[ERROR] Unable to upload "/home/me/mytheme/fields.json". The post failed because "mytheme/fields.json" was not found in portal XXXXXXX. Unable to find model with id 34719888101
[ERROR] Uploading file "/home/me/mytheme/images/template-previews/membership-reset-password-request.png" to "mytheme/images/template-previews/membership-reset-password-request.png" failed
[ERROR] Unable to upload "/home/me/mytheme/images/template-previews/membership-reset-password-request.png". The post failed because "mytheme/images/template-previews/membership-reset-password-request.png" was not found in portal XXXXXXX. Unable to find model with id 34719892051

 

Deleting the folder for my theme in the design manager and starting over didn't help. Same error.

 

Github ticket here: https://github.com/HubSpot/hubspot-cms-tools/issues/322

0 Upvotes
1 Accepted solution
sst
Solution
Member

CMS CLI upload error

SOLVE
0 Upvotes
DStaniszewski
Participant

CMS CLI upload error

SOLVE

Hi, I saw this was fixed but I am getting a similar error: 

 

[ERROR] Uploading file "/Users/dylan/local-cms-dev/BabyScripts_March2020/fields.json" to "Babyscripts_Dev/fields.json" failed
[ERROR] internal error
[ERROR] no controlling_value_regex is set for field 'body_font_weight'
[ERROR] no controlling_field is set for field 'body_font_weight'
[ERROR] theme.global_fonts.primary_font.color is not a valid path to a property
[ERROR] Not a valid choice for body_text_font
[ERROR] Not a valid choice for custom_heading5_family
[ERROR] theme.global_fonts.secondary_font.color is not a valid path to a property
[ERROR] theme.global_fonts.secondary_font.font is not a valid path to a property
[ERROR] theme.global_fonts.secondary_font.font_set is not a valid path to a property
[ERROR] Not a valid choice for custom_heading6_family
[ERROR] theme.global_fonts.secondary_font.color is not a valid path to a property
[ERROR] theme.global_fonts.secondary_font.font is not a valid path to a property
[ERROR] theme.global_fonts.secondary_font.font_set is not a valid path to a property
[ERROR] no controlling_value_regex is set for field 'h1_font_weight'
[ERROR] no controlling_field is set for field 'h1_font_weight'
[ERROR] theme.global_fonts.primary_font.color is not a valid path to a property
[ERROR] no controlling_value_regex is set for field 'h3_font_weight'
[ERROR] no controlling_field is set for field 'h3_font_weight'
[ERROR] Not a valid choice for custom_heading4_family
[ERROR] theme.global_fonts.secondary_font.color is not a valid path to a property
[ERROR] theme.global_fonts.secondary_font.font is not a valid path to a property
[ERROR] theme.global_fonts.secondary_font.font_set is not a valid path to a property
[ERROR] theme.global_fonts.secondary_font.color is not a valid path to a property
[ERROR] theme.global_fonts.secondary_font.font is not a valid path to a property
[ERROR] theme.global_fonts.secondary_font.font_set is not a valid path to a property
[ERROR] theme.global_fonts.primary_font.color is not a valid path to a property
[ERROR] theme.global_fonts.primary_font.color is not a valid path to a property
[ERROR] no controlling_value_regex is set for field 'h4_font_weight'
[ERROR] no controlling_field is set for field 'h4_font_weight'
[ERROR] theme.global_fonts.primary_font.color is not a valid path to a property
[ERROR] no controlling_value_regex is set for field 'h2_font_weight'
[ERROR] no controlling_field is set for field 'h2_font_weight'
[ERROR] theme.global_fonts.primary_font.color is not a valid path to a property
[ERROR] theme.global_fonts.primary_font.color is not a valid path to a property
[ERROR] Not a valid choice for custom_heading2_family
[ERROR] no controlling_value_regex is set for field 'h6_font_weight'
[ERROR] no controlling_field is set for field 'h6_font_weight'
[ERROR] theme.global_fonts.primary_font.color is not a valid path to a property
[ERROR] theme.global_fonts.primary_font.color is not a valid path to a property
[ERROR] no controlling_value_regex is set for field 'h5_font_weight'
[ERROR] no controlling_field is set for field 'h5_font_weight'
[ERROR] theme.global_fonts.secondary_font.color is not a valid path to a property
[ERROR] theme.global_fonts.secondary_font.font is not a valid path to a property
[ERROR] theme.global_fonts.secondary_font.font_set is not a valid path to a property
[ERROR] Not a valid choice for custom_heading1_family
[ERROR] theme.global_fonts.primary_font.color is not a valid path to a property
[ERROR] theme.global_fonts.secondary_font.color is not a valid path to a property
[ERROR] theme.global_fonts.secondary_font.font is not a valid path to a property
[ERROR] theme.global_fonts.secondary_font.font_set is not a valid path to a property
[ERROR] theme.global_fonts.primary_font.color is not a valid path to a property
[ERROR] theme.global_fonts.primary_font.color is not a valid path to a property
[ERROR] Not a valid choice for custom_heading3_family
[ERROR] theme.global_fonts.secondary_font.color is not a valid path to a property
[ERROR] theme.global_fonts.secondary_font.font is not a valid path to a property
[ERROR] theme.global_fonts.secondary_font.font_set is not a valid path to a property
[ERROR] theme.global_fonts.primary_font.color is not a valid path to a property
[ERROR] theme.global_fonts.primary_font.color is not a valid path to a property

 

field.json fetched from live theme and I am trying to copy it to a dev account. Everything else uploaded successfully. 

buddhabuddy
Participant

CMS CLI upload error

SOLVE

Did you discover the reason/fix for this?
We have a hubspot developed theme that can't be cloned because of this.

0 Upvotes
DStaniszewski
Participant

CMS CLI upload error

SOLVE

I had to use a work around for this. I believe I had to fetch the original file, not make any changes, upload it to the dev account and then make the changes to the fonts manually. The error was occuring when the font files were not uploading properly for some reason. I had to redownload the fonts into the file manager and put them in using new file paths. 

0 Upvotes
buddhabuddy
Participant

CMS CLI upload error

SOLVE

Thanks for the super quick reply!

I'm going through all the properties to fix them and it seems to be getting better but still a few #nulls coming through in the theme 😅

0 Upvotes
DStaniszewski
Participant

CMS CLI upload error

SOLVE

Yeah unfortunately this was pretty tedious to fix since I had to go through and make the corrections line by line. 

0 Upvotes
Kevin-C
Recognized Expert | Partner
Recognized Expert | Partner

CMS CLI upload error

SOLVE
Hey Dylan,

On my phone so I haven’t dug too deep but your error looks a little different from the initial post.
Checkout this link by the amazing Stephanie O'Gay Garcia explaining how to use the controlling values:
https://www.stephanieogaygarcia.com/hubspot-website-development/set-a-hubspot-module-fields-display-...
Kevin-C
Recognized Expert | Partner
Recognized Expert | Partner

CMS CLI upload error

SOLVE

Tagging in @Stephanie-OG !

sst
Solution
Member

CMS CLI upload error

SOLVE

Update: fixed.

0 Upvotes
Kevin-C
Recognized Expert | Partner
Recognized Expert | Partner

CMS CLI upload error

SOLVE

Hey @sst 

 

Whats was the issue?

sst
Member

CMS CLI upload error

SOLVE