Blog Author Page Not Generating

SOLVE
jvargas2
Participant

I have a few authors who are not having their page be generated as expected. I currently have multiple blogs. When you click on an author name it takes you to  /[blog-slug]/author/[author-slug] where usually the author template takes over.

 

However, I have about 6 authors who just get a 404 when you go to their page. This feels like a HubSpot bug rather than anything I can take care of myself. Any idea why this is happening?

 

Here's an example where there are quite a few of the authors with broken pages: https://daml.com/company?page=3

0 Upvotes
1 Accepted solution

Accepted Solutions
Indra
Solution
Top Contributor | Diamond Partner

@Hi @jvargas2,

 

On the author link, I see a query_dict of hsLang=en. Is the blog and/or author setup multilingual?

Is it's good to check out the following:

 

Check out if the language of your blogs is set inside the HubSpot blog settings.

 

Check if the author is setup multilingual. You can see this by going to the blog author and check if a language is behind there names.

hs-authors.png

If the language of an autor recently setup to a specific language, you will need to reconnect the author to the written/original blogs. By default, HubSpot authors are not setup multilingual so you can select autors on every language since most use of a autor is only for the name and e-mail. But since a author also has an bio, you also have the possibility this translate this. Therefore it's possible to create them multilingual. One bad thing is that you will need to reconnect the autor again to the right blog posts. So try to select the autor again to the post and try checking out the author link again.

 

Good to know. I had has caching issues with playing around and setting upmultilingual autors and tags, so also check the links in a incognito window and try use the Buster Cache by adding the following to your author links: www.sample.com/blog/author/author-name?hsCacheBuster=2454 You can change the number 2454 for refreshing the cache.


Bureau Vet

Did my post solve your question? Help the community by marking it as a solution

View solution in original post

0 Upvotes
2 Replies 2
Indra
Solution
Top Contributor | Diamond Partner

@Hi @jvargas2,

 

On the author link, I see a query_dict of hsLang=en. Is the blog and/or author setup multilingual?

Is it's good to check out the following:

 

Check out if the language of your blogs is set inside the HubSpot blog settings.

 

Check if the author is setup multilingual. You can see this by going to the blog author and check if a language is behind there names.

hs-authors.png

If the language of an autor recently setup to a specific language, you will need to reconnect the author to the written/original blogs. By default, HubSpot authors are not setup multilingual so you can select autors on every language since most use of a autor is only for the name and e-mail. But since a author also has an bio, you also have the possibility this translate this. Therefore it's possible to create them multilingual. One bad thing is that you will need to reconnect the autor again to the right blog posts. So try to select the autor again to the post and try checking out the author link again.

 

Good to know. I had has caching issues with playing around and setting upmultilingual autors and tags, so also check the links in a incognito window and try use the Buster Cache by adding the following to your author links: www.sample.com/blog/author/author-name?hsCacheBuster=2454 You can change the number 2454 for refreshing the cache.


Bureau Vet

Did my post solve your question? Help the community by marking it as a solution

View solution in original post

0 Upvotes
jvargas2
Participant

Thank you for pointing out the language issue! For anyone else, all my authors who were leading to 404 pages had their language set to "English - United States". Changing their language to just "English" fixed it right away without needing to clear cache.

0 Upvotes