CMS Development

vin-aws
Contributor

Beta Design Manager "Cannot resolve property..."

Seems like there is a bug in the beta design manager unless if I'm doing something incorrectly. When referencing a custom module's fields I am receiving warnings in the console:

Cannot resolve property 'propertyName' in [{property1=..., property2=...}]

These warnings do not affect the performance of the module as everything is working still. Even when copying the snippet straight from the field I am receiving these warnings. Any idea why? Seems like a bug to me.

0 Upvotes
4 Replies 4
dcronk
Participant

Beta Design Manager "Cannot resolve property..."

I'm still seeing this in the template when I'm using a repeatable group in a module. 

 

 Cannot resolve property 'section_title' in '0'

I assume 0 is the starting value in a grouped field.   "section_title" is my own naming.  I can still save the template and seems to be working fine.    

 

I wasn't seeing this when I created the template and worked in it extensively.  I went back a few days later and now see the warnings.

0 Upvotes
tjoyce
Recognized Expert | Elite Partner
Recognized Expert | Elite Partner

Beta Design Manager "Cannot resolve property..."

@vin-aws - 

We have seen some new warnings that are related to reserved keywords or indexes in the beta version. Perhaps, changing the property name just to test and see if the warning goes away might lead us to the root of the warning. I'd be interested to know what you find out.


If this answer helped, please, mark as solved 😄


tim@belch.io | forms.belch.io | Design your own Beautiful HubSpot Forms; No coding necessary.

 

Drop by and say Hi to me on slack.

0 Upvotes
vin-aws
Contributor

Beta Design Manager "Cannot resolve property..."

Went back to do what you suggested but the errors are gone now. Maybe hubspot figured it out.

tjoyce
Recognized Expert | Elite Partner
Recognized Expert | Elite Partner

Beta Design Manager "Cannot resolve property..."

Interesting.... lol