Blog, Website & Page Publishing

MBerkshire
Member

Web address / URL only works with "en-gb"

SOLVE

I have built a website through hubspot hwoever, although my domain is domain.co.uk and redirected through www.domain.co.uk,  when i publish the page then search it in my browser it will only load if it has /en-gb/ at the end of the url. I dont want this to happen but i can;t figure out how to stop it? 

2 Accepted solutions
Jnix284
Solution
Most Valuable Member | Elite Partner
Most Valuable Member | Elite Partner

Web address / URL only works with "en-gb"

SOLVE

Hi @MBerkshire you'll want to update your language settings under Content > Domains & URLs > Language Settings to make sure you aren't using the "use prefix in slug" option:

Jnix284_0-1712836316095.png

 


If my reply answered your question please mark it as a solution to make it easier for others to find.



Jennifer Nixon - Delivery Lead at Aptitude 8

connect with Jen on Linkedin

View solution in original post

0 Upvotes
Jnix284
Solution
Most Valuable Member | Elite Partner
Most Valuable Member | Elite Partner

Web address / URL only works with "en-gb"

SOLVE

@dgalant1 have you also confirmed that you didn't add the language on the individual page in the Settings > Language here:

Jnix284_0-1712938022905.png

 

This should be blank or it will add the language slug at the page level.


If my reply answered your question please mark it as a solution to make it easier for others to find.



Jennifer Nixon - Delivery Lead at Aptitude 8

connect with Jen on Linkedin

View solution in original post

4 Replies 4
MBerkshire
Member

Web address / URL only works with "en-gb"

SOLVE

Thank you for all your help, it was the language on the page settings however, prior to this, turnin goff the prefix didnt remove it. it only dissapeared when i changed the page settings. 

Jnix284
Solution
Most Valuable Member | Elite Partner
Most Valuable Member | Elite Partner

Web address / URL only works with "en-gb"

SOLVE

Hi @MBerkshire you'll want to update your language settings under Content > Domains & URLs > Language Settings to make sure you aren't using the "use prefix in slug" option:

Jnix284_0-1712836316095.png

 


If my reply answered your question please mark it as a solution to make it easier for others to find.



Jennifer Nixon - Delivery Lead at Aptitude 8

connect with Jen on Linkedin

0 Upvotes
dgalant1
Participant

Web address / URL only works with "en-gb"

SOLVE

Jennifer,

I have the exact same issue and I have gone throught the documentation several times and cannot get the page to load. Same as the OP, my domain is https://avarenventures.com/ which is not loading (404 Error via HS) or redirecting to the English version of the page https://avarenventures.com/en-us/.  Cloudflare is my domain registrar and HS automatically configured the DNS settings. 
I have tried everything, including disconnecting the domain, clearing out all the DNS entries, clear cookies, etc. 

 

I really think there is an issue on the HS side.  This seems like a bug or UX issue... This should not be this hard to setup. 

 

Screenshot 2024-04-12 at 11.42.14 AM.png

 

0 Upvotes
Jnix284
Solution
Most Valuable Member | Elite Partner
Most Valuable Member | Elite Partner

Web address / URL only works with "en-gb"

SOLVE

@dgalant1 have you also confirmed that you didn't add the language on the individual page in the Settings > Language here:

Jnix284_0-1712938022905.png

 

This should be blank or it will add the language slug at the page level.


If my reply answered your question please mark it as a solution to make it easier for others to find.



Jennifer Nixon - Delivery Lead at Aptitude 8

connect with Jen on Linkedin