Thoughts On Beta Editing for Web Pages

Highlighted
Regular Contributor

Thoughts on the beta editing experience for website, landing and blog posts? I have to be honest, I don't like it and it's very glitchy. I tried it for a few days then went back to the old. Hopefully there will be more updates made before it roles out March 1. 

Reply
0 Upvotes
8 Replies 8
Highlighted
Community Manager

Hi @ITMarketer,

 

Thank you for your feedback. I will pass along your thoughts to the team.

 

Best,

Jenny


We are excited to announce that the Community will be launching a weekly newsletter on November 2, 2020!
Sign up today!
Reply
0 Upvotes
Highlighted
HubSpot Product Team

Hey there, 

 

Thanks for the feedback. Is there anything in particular you found glitchy about it? Would love to hear how we can improve.

 

Thanks,

Katie

Reply
0 Upvotes
Highlighted
Esteemed Contributor

Not OP but just to give my thoughts, I haven't experienced any glitches but what I dislike about it is that it takes options away from me, in that it's an overlay (in the same way the form editor is) which means you can't access the Hubspot menu when you're editing a page, and it does this without seemingly adding anything to the UX.

Reply
0 Upvotes
Highlighted
Occasional Contributor

Re: glitches - when editing a page/post, it seems impossible now to edit links. When you click on the link in edit mode, instead of popping up the little edit box, it just follows the link and so actually loads the destination page in the window. The only way I've been able to edit links is by going into the source code. It's very frustrating and has meant I've had to go back to the old editor. Please fix it before the old editor goes away!

 

(It actually seems to work ok the first couple of times you do it, i.e. the edit link box appears ok, but then reverts back to loading the destination page again)

 

Also, not a glitch but a minor irritation, I often want to preview a page in a separate window while still keeping the editor window open. In the old editor I could do this with one click, now it seems to take several as you're taken away from the editing page immediately, have to open the preview in a new window, and then hit 'back' to get your editor back again.

Highlighted
Esteemed Contributor

"Also, not a glitch but a minor irritation, I often want to preview a page in a separate window while still keeping the editor window open. In the old editor I could do this with one click, now it seems to take several as you're taken away from the editing page immediately, have to open the preview in a new window, and then hit 'back' to get your editor back again."

 

Great point, I very much agree with this.

Highlighted
Occasional Contributor

Chiming in - I think the update looks great, but I also agree with Kate Pidgeon and piersg on the following:

 

"Also, not a glitch but a minor irritation, I often want to preview a page in a separate window while still keeping the editor window open. In the old editor I could do this with one click, now it seems to take several as you're taken away from the editing page immediately, have to open the preview in a new window, and then hit 'back' to get your editor back again."

 

Additionally, I've found that there are times when attempting to edit content in modules and the UI will not allow me to click into them to edit without refreshing.

Reply
0 Upvotes
Highlighted
HubSpot Product Team

Thanks as well for the feedback on the preview! I can definitely have the team take a look at making this smoother.

Highlighted
HubSpot Product Team

Thanks for the info. We're investigating the link issue on our side right now. If you get a chance, would you be willing to DM me with information about your Chrome version, a link to the page or post you're seeing the link issue on, as well as a screenshot of the Console? 

Reply
0 Upvotes