No Alt-Text recognition in landingpage template pics

SOLVE
Elli_Andre
Participant

Hi Folks! 

 

I looove how easy it is to put up a landing page in hubspot marketing cos with all the build in seo checks. But I have encountered one small problem, that affects my seo ranking: I have build in pictures in my landing page templates and all of them have an alt-text-tag next to the HS-data-source URL. But the seo tool still gives me feedback, that there are no alt texts to the pics. Maybe one of you pros can help me find the fix? 

 

THANKS!

 

 Pics_alttext1.PNGPics_alttext2.PNG

0 Upvotes
1 Accepted solution

Accepted Solutions
aliciaw
Solution
Top Contributor

Hey @Elli_Andre

In the second screenshot you provided, it definitely looks like those images include alt text with the proper syntax, but it does look like that's only 3 sample images, and the SEO optimizer has listed at least 7. Do you have other images on the page that might not have this text? If you link to this blog post, perhaps someone could confirm by looking at the source code. 

View solution in original post

0 Upvotes
1 Reply 1
aliciaw
Solution
Top Contributor

Hey @Elli_Andre

In the second screenshot you provided, it definitely looks like those images include alt text with the proper syntax, but it does look like that's only 3 sample images, and the SEO optimizer has listed at least 7. Do you have other images on the page that might not have this text? If you link to this blog post, perhaps someone could confirm by looking at the source code. 

View solution in original post

0 Upvotes