Landingpage link doesn't work

SOLVE
HBerendsen
Member

Landingpage link doesn't work when publiced. In concept mode the link does work, but when I publish the page it stops working (Picture down below). Anybody any idea how I can fix this? Schermafbeelding 2021-04-12 om 16.50.05.png

0 Upvotes
1 Accepted solution

Accepted Solutions
HBerendsen
Solution
Member

Hi Tiphaine!

 

I've just cloned the page again, and these are my settings (They are in dutch, I'm sorry) 

Schermafbeelding 2021-04-13 om 16.44.30.png

As you can see it says "er is geen primair domein ingesteld....." which means "There is no primary domain setup....". 

 

When I press publish, you can see below that the I get the hs-sites domain again.

Schermafbeelding 2021-04-13 om 16.45.16.png

 

When I press this URL, it says that the page isn't availible again.

 

I hope the screenshots help. 

 

Best,

Huub

 

View solution in original post

0 Upvotes
12 Replies 12
TiphaineCuisset
Community Manager

Hi @HBerendsen 

 

Thank you for reaching out. 

 

Would you mind trying to clear your cache following those steps, as well as trying with another browser and with an incognito window? 

 

If this is still happening, could you clarify what steps exactly you're taking and where exactly you're getting stuck? The more information, screenshots, and details you can provide the better I can assist!

 

Thank you!

Best

Tiphaine


Saviez vous que la Communauté est disponible en français?
Rejoignez les discussions francophones en changeant votre langue dans les paramètres !

Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !


HBerendsen
Member

Hi! Thanks for your respons. 

 

I've already cleared my cache, which didn't help unfortunately. I've also used a different browser, also without success. 

 

The problem: my landing page link doesn't work when published. When I click the link in concept mode it does, but when I publish the page, it stops working. (See 

pictures below for concept mode)

Schermafbeelding 2021-04-13 om 10.12.18.pngSchermafbeelding 2021-04-13 om 10.09.07.png

See pictures below when published:

Schermafbeelding 2021-04-13 om 10.15.46.pngSchermafbeelding 2021-04-13 om 10.15.58.png

 

It would be great if you could help me with this! 

 

Best,

Huub

 

0 Upvotes
TiphaineCuisset
Community Manager

Hi @HBerendsen 

 

Thank you for your reply and the screenshots/details

 

After investigating I think this is happening because you downgraded from a paid subscription to the free CRM and that the current URL is under the hs-sites format. As explained in this knowledge base article:

If you're downgrading a paid Marketing Hub account to a free account, your existing landing pages will remain published in read-only mode for 90 days. After 90 days, those pages will be unpublished and archived. This includes all pages on custom domains and HubSpot's default hs-sites domain.

 

Free accounts come with a HubSpot branded domain, which will appear as yourcompanyname.hubspotpagebuilder.com. This free domain is based on the company name associated with your account, and can't be customized.  You can publish any unpublished landing pages to the HubSpot branded domain. You can also create new pages on the domain, with a limit of 20 total landing pages per free account.

 

Can you try to edit the page to change the URL? If this doesn't seem possible, could you try cloning the page and see if that works? 

 

Thank you!

Best

Tiphaine

 

( thank you @webdew for helping!)

 


Saviez vous que la Communauté est disponible en français?
Rejoignez les discussions francophones en changeant votre langue dans les paramètres !

Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !


0 Upvotes
HBerendsen
Member

Hi Tiphaine!

 

I indeed think that's the problem. However when I clone the page or I make a new page from scratch the URL will be a hs-site, eventhough it should appear as portal-joboti.hubspotpagebuilder.com. I've tried it a couple of times, without success. Do you have any idea how this can happen?

 

Best,

Huub

0 Upvotes
TiphaineCuisset
Community Manager

Hi @HBerendsen 

 

Thank you for your reply. 

I tested on a test portal and I don't see the same thing in the "Page URL" setting as you, that's strange. Can you confirm that when you start from scratch or clone the page, when you go to the Page URL setting you see "There is no primary domain setup...." etc ? 

 

Can you confirm what happens when you publish this clone or this new page? Do you get the hs-sites domain again? 

 

Thank you for your cooperation!

Best

Tiphaine


Saviez vous que la Communauté est disponible en français?
Rejoignez les discussions francophones en changeant votre langue dans les paramètres !

Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !


0 Upvotes
HBerendsen
Solution
Member

Hi Tiphaine!

 

I've just cloned the page again, and these are my settings (They are in dutch, I'm sorry) 

Schermafbeelding 2021-04-13 om 16.44.30.png

As you can see it says "er is geen primair domein ingesteld....." which means "There is no primary domain setup....". 

 

When I press publish, you can see below that the I get the hs-sites domain again.

Schermafbeelding 2021-04-13 om 16.45.16.png

 

When I press this URL, it says that the page isn't availible again.

 

I hope the screenshots help. 

 

Best,

Huub

 

View solution in original post

0 Upvotes
HBerendsen
Member

I see that is has been fixed! Thanks for your help!

TiphaineCuisset
Community Manager

Hi @HBerendsen 

 

Thank you for your reply!

 

Yeah I reached out to the team with it and we fixed that! You will just need to go into your landing pages > open the editor for each > hit update in the top right corner to push the domain change live. It's already done so for the provided page, and it's now correctly showing at the URL http://portal-joboti.hubspotpagebuilder.com/use-case-whatsapp-joboti This update does take a minute to provision, so after you publish, you'll want to wait for a few then check each page. 

 

Thank you for your patience & cooperation on this!

Have a lovely day, 

Tiphaine


Saviez vous que la Communauté est disponible en français?
Rejoignez les discussions francophones en changeant votre langue dans les paramètres !

Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !


0 Upvotes
webdew
Top Contributor | Diamond Partner

Hi @HBerendsen ,

I suspect the URL might not match it in the settings exactly. So for instance, the URL in the page editor might say something like "www.example.com" but if the live URL is from a link which links to "www.example.com?abcde", then it's possible for that to show as an unavailable page.

 

Hope this helps!

If we were able to answer your query, kindly help the community by marking it as a solution.

Thanks and Regards.

0 Upvotes
HBerendsen
Member

Hi!

 

Thanks for your respons. I just checked whether the URL's were different, but that's unfortunately not the case. They are the exact same. 

I hope you can help me further!

 

Best,

Huub

0 Upvotes
webdew
Top Contributor | Diamond Partner

Hi @HBerendsen , may be some backend problem then. Connect to HubSpot support by clicking Help button in your account.

0 Upvotes
webdew
Top Contributor | Diamond Partner

Hi @HBerendsen , 

The type of URL that is being shown here is a systems domain (see here: https://knowledge.hubspot.com/cos-general/display-system-subdomains-in-your-domain-manager) and these are used when a Domain is not connected for a specific content type. You can check to ensure that they have connected a domain for the Content type that you are looking to use for these pages. 

Hope this helps!

0 Upvotes