Blog, Website & Page Publishing

Npatsalides
Participant

Homepage slug cannot be left empty?

SOLVE

We recently launched our site. Upon launch everything was ok.

We had domain.com, domain.co.uk redirect to domain.com/en-gb/ and domain.fr redirect to .com/fr/

 

The content slugs on all the homepages were left empty at launch and everything was ok.

 

Today we noticed that although those content slugs were empty, they now have values added. They now appear as domain.com/en-gb/en-gb/ and domain.com/fr/fr/.

 

The team confirmed they haven't added these. They appear to have added themselves.

 

Every time we fix this, and remove the slug and then re-publish the changes, the changes appear to have been accepted on the confirmation screen where the link is displayed to say the changes have been updated.

 

If you go back into the page to edit it, switching to the settings tab, the content slug is showing the duplicated trail again domain.com/en-gb/en-gb/ - without any change being made.

 

In the case of the example on: https://knowledge.hubspot.com/cos-general/how-to-manage-multi-language-content-with-hubspots-cos it clearly shows 'home' used in the slug.

 

I don't recall any of our home pages having 'home' in the content slug before when the site went live, neither when we had our staging environment.

 

Does a value need to be included for the content slug property to save that change? And is there a property I can place in there which will enable it to save without adding a value to the url for the home page.

 

In the case of en-gb:

 

  • I do not want domain.com/en-gb/home/.
  • I definitely do not want domain.com/en-gb/en-gb/.
  • What I do want is domain.com/en-gb/

Also not sure why this change happened. I'm hoping its simple to fix - i.e. just add a '/' into the slug or some other character as leaving the slug blank is causing an issue, feels like it's not saving the change, or overwriting it for another reason.

 

I also noticed the hover text on the page url field which states 'Only use '/' to publish to the home page'.

0 Upvotes
1 Accepted solution
JessicaH
Solution
HubSpot Alumni
HubSpot Alumni

Homepage slug cannot be left empty?

SOLVE

Hi @Npatsalides,

 

Thanks for reaching out.

It looks like you have access to HubSpot Technical Support . As troubleshooting this further will involve sharing information specific to your account and specific examples, partnering with them will be the best next step.

 

Take care!

Jess


Wusstest du, dass es auch eine DACH-Community gibt?
Nimm an regionalen Unterhaltungen teil, in dem du deine Spracheinstellungen änderst !


Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !


View solution in original post

0 Upvotes
1 Reply 1
JessicaH
Solution
HubSpot Alumni
HubSpot Alumni

Homepage slug cannot be left empty?

SOLVE

Hi @Npatsalides,

 

Thanks for reaching out.

It looks like you have access to HubSpot Technical Support . As troubleshooting this further will involve sharing information specific to your account and specific examples, partnering with them will be the best next step.

 

Take care!

Jess


Wusstest du, dass es auch eine DACH-Community gibt?
Nimm an regionalen Unterhaltungen teil, in dem du deine Spracheinstellungen änderst !


Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !


0 Upvotes