Google Results URL Has ?hs_amp=true at End

SOLVE
Highlighted
Occasional Contributor

When I search for my article on Google (on my desktop) and click on the result, it brings me to my blog page URL but it has "?hs_amp=true" at the end.  

 

The resulting page has all of the extra content stripped away. It's basically only the article and the photos. Why is Google adding this "?hs_amp=true" at the end of my URL? How can I get it to disappear?

 

Note: I tried pasting in the correct URL as "cannonical" on the settings page. I'll have to wait and see if that changes anything.

 

Another Note: There is no "Google AMP" section at the bottom of my "Publish or Schedule" page.

 

Reply
0 Upvotes
1 Accepted solution

Accepted Solutions
Highlighted
Community Thought Leader | Diamond Partner

Hi @DarrenJansen


AMP results should only show in mobile search results. AMP results in desktop search are typically considered a bug. Hopefully, this will stop happening but you should perhaps try to report it to Google. 

 

Here's a recent-ish article on that: https://searchengineland.com/google-amp-breaks-desktop-search-results-259840

 

Might be worth checking your HubSpot AMP config with HubSpot support though, just to make sure everything is in order with your URLs. Also, you could use Search Console to see if it reports any errors with your AMP pages: https://searchengineland.com/google-search-console-adds-amp-error-report-240572

 

The AMP format does of course strip away most styling to allow for faster loading on mobile devices (further accelerated by their caching the content). If you do not need or want AMP versions of your pages, you can simply turn it off in your blog settings: 

 

AMP.png

 

Hope this helps.

Phil Vallender | Inbound marketing for B2B technology companies
3 Replies 3
Highlighted
Community Thought Leader | Diamond Partner

Hi @DarrenJansen


AMP results should only show in mobile search results. AMP results in desktop search are typically considered a bug. Hopefully, this will stop happening but you should perhaps try to report it to Google. 

 

Here's a recent-ish article on that: https://searchengineland.com/google-amp-breaks-desktop-search-results-259840

 

Might be worth checking your HubSpot AMP config with HubSpot support though, just to make sure everything is in order with your URLs. Also, you could use Search Console to see if it reports any errors with your AMP pages: https://searchengineland.com/google-search-console-adds-amp-error-report-240572

 

The AMP format does of course strip away most styling to allow for faster loading on mobile devices (further accelerated by their caching the content). If you do not need or want AMP versions of your pages, you can simply turn it off in your blog settings: 

 

AMP.png

 

Hope this helps.

Phil Vallender | Inbound marketing for B2B technology companies
Highlighted
Occasional Contributor

Hi Phil,

 

I searched ?hs_amp=true and didn't find anything, so thanks a lot for the info. It's very helpful.

 

I think this might be a job for Hubspot support. Only this page is doing this . . .

 

Thanks again,

 

Darren

Reply
0 Upvotes
Highlighted
Occasional Contributor

I ended up going to my blog settings and turning off the AMP globally. I checked Google again the next day and the link still includes "?hs_amp=true" but the page looks much better now. That's the important thing! thanks

Reply
0 Upvotes