Blog, Website & Page Publishing

RoxyDHFH
Participant

Favicon not working

SOLVE

I've uploaded the favion and it's not working. It's been days and still nothing.

 

How can I fix it? Is it because on the free version? All the other website I managed on HubSpot on paid versions have no issues whatsoever. It's a bit odd. Yet 2 free versions, not working.

 

HubSpot doesn't seem to imply free version doesn't allow for a favicon?

0 Upvotes
1 Accepted solution
Jon-May
Solution
Participant | Diamond Partner
Participant | Diamond Partner

Favicon not working

SOLVE

Hi @RoxyDHFH,

Would suggest doing a hard refresh. If you're on Google Chrome, try Shift + Refresh, otherwise try using another device.

If that still doesn't work, make sure you've set the favicon on the right domain, it's easy to set it on the system domain, but not the live/custom domain:

JonMay_0-1658932113482.png

 

 

View solution in original post

5 Replies 5
LDemaj
Participant

Favicon not working

SOLVE

I have a similar issue, but then at the page settings I do not have page branding. I've set the general account branding, but that does not seem to be doing aything!

 Hubspot SC.png

DElsey
Participant

Favicon not working

SOLVE

I have the same issue. The favicon request returns a 404 - there is no "branding" tab on Website > Pages, but it can be set on Account Defaults > My Brand Kit

DElsey_0-1663977261439.png

DElsey_1-1663977297020.png

 

 

0 Upvotes
Jon-May
Solution
Participant | Diamond Partner
Participant | Diamond Partner

Favicon not working

SOLVE

Hi @RoxyDHFH,

Would suggest doing a hard refresh. If you're on Google Chrome, try Shift + Refresh, otherwise try using another device.

If that still doesn't work, make sure you've set the favicon on the right domain, it's easy to set it on the system domain, but not the live/custom domain:

JonMay_0-1658932113482.png

 

 

RoxyDHFH
Participant

Favicon not working

SOLVE

awesome! it was the second thing. I didn't realise there were 2 areas to set it up. Must have set it up this way on the others without realising. thanks!

ashleyidesign
Top Contributor | Partner
Top Contributor | Partner

Favicon not working

SOLVE

It's possible the site is just cached on your machine and it hasn't updated yet. If you can share the URL then someone else can see if it's working for them.