Hola! ¡Tenemos nuestra Comunidad en Español!

Design Question: Embedded content showing up differently

resolver
Colaborador destacado

We have had A LOT of bizarre things happen with our site design (the font weight suddenly changed without anyone touching the css??) sometimes embedded objects will show up correctly and sometimes they will show up differently, even while using the exact same embed code.

 

Can anyone tell me why some blog posts (using the same template) allow the embed code to display properly:

<iframe style="margin: 0px auto; display: block;" allow="autoplay" xml="lang" src="https://player.pippa.io/5ac0f9c42df344f54cb153d1/episodes/cats-peeing-outside-the-litter-box-causes-..." width="100%" height="110px" frameborder="0"></iframe>

 

Screen Shot 2019-09-29 at 11.13.05 AM.png

 

And others it seems like no matter what I do, it somehow changes the code and forces lots of extra space at the bottom of the player?

Screen Shot 2019-09-29 at 11.13.28 AM.png

 

Thanks in advance!

Mia

Responder
0 Me gusta
1 Soluciones aceptada

Soluciones aceptadas
Equipo de producto de HubSpot

Hey @MiaPV , thanks for the response!

 

I tested this out on my end and it looks like the iframe code does not accept the use of "auto" for the width parameter. I changed this out to width="560" height="110" instead and that seems to have fixed the height issue. Check out the changes on this preview link: https://www.preventivevet.com/?hs_preview=jsyJcTEi-5443951703

 

Here is the code snippet in full, for reference

<iframe style="margin: 0px auto; display: block;" allow="autoplay" xml="lang" src="https://player.pippa.io/5ac0f9c42df344f54cb153d1/episodes/cats-peeing-outside-the-litter-box-causes-..." width="560" height="110" frameborder="0" data-service="player.pippa"></iframe>

 

Cheers, 

Jocelyn

4 Respuestas 4
Equipo de producto de HubSpot

Hey MiaPV Emoticono feliz

 

Thanks for providing screenshots of your blog articles, with the URL visible in the address bar. Looking at the souce code of your blog article (How to Clean Cat **bleep** and Poop Accidents), the <iframe> code currently in use on the page has height and width parameters that are adding white space below the player.

<iframe style="margin: 0px auto; display: block;" allow="autoplay" xml="lang" src="https://player.pippa.io/5ac0f9c42df344f54cb153d1/episodes/cats-peeing-outside-the-litter-box-causes-..." width="560" height="315" frameborder="0" data-service="player.pippa"></iframe>

iframe code with width and height parameters.pngcurrent code

Try changing this to width="100%" height="auto" for your embedded player to look like this!
proposed changes to iframe width and height.pngproposed changes

Let me know if you have any questions Emoticono feliz

Jocelyn

 

Colaborador destacado

Thanks for the response @joceyng - the problem is, I have been doing exactly what you said, but for some reason the editor won't save the code the same way that I put it in. The screen shots below will show you exactly what is happening. I am adding the code, clicking save, and then it still shows up weirdly. When I go back into the editor, it has assigned a width and height that adds space.

 

Screen Shot 2019-09-30 at 12.52.01 PM.png

 

Screen Shot 2019-09-30 at 12.52.12 PM.png

Screen Shot 2019-09-30 at 12.52.36 PM.png

Equipo de producto de HubSpot

Hey @MiaPV , thanks for the response!

 

I tested this out on my end and it looks like the iframe code does not accept the use of "auto" for the width parameter. I changed this out to width="560" height="110" instead and that seems to have fixed the height issue. Check out the changes on this preview link: https://www.preventivevet.com/?hs_preview=jsyJcTEi-5443951703

 

Here is the code snippet in full, for reference

<iframe style="margin: 0px auto; display: block;" allow="autoplay" xml="lang" src="https://player.pippa.io/5ac0f9c42df344f54cb153d1/episodes/cats-peeing-outside-the-litter-box-causes-..." width="560" height="110" frameborder="0" data-service="player.pippa"></iframe>

 

Cheers, 

Jocelyn

Colaborador destacado

That worked (although I swear it wasn't taking my code when I had tried setting the height previously)!! Thank you Emoticono feliz