Blog comments not giving the option to approve

hannah_andrews
Member

We use wordpress for our website and blog. I used to receive notifications on our wordpress dashboard when we received a new comment on a blog post. I would then be able to approve the comment to post, or delete, mark as spam, etc. That no longer happens after adding the hubspot chat feature to our webpage. I now only receive an email notification from hubspot letting me know that a comment was left. The subject of the email is: "New submission on Collected Forms '#commentform .comment-form'". There is no option to view the comment anywhere other than the body of the email and  no option to approve or delete the comment. The comment doesn't automatically post to the blog either. This is all pretty far over my head - any help would be greatly appreciated!

5 Replies 5
PamCotton
Community Manager

Hello @hannah_andrews 

 

I would like to tag our top experts on this matter to help, @trevorjones71@Josh@Joe-Kelp  would you be able to help with @hannah_andrews question about blog comments in Wordpress?

 

Thank you,

Pam

Você sabia que a Comunidade está disponível em outros idiomas?
Participe de conversas regionais, alterando suas configurações de idioma !


Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !


0 Upvotes
Josh
Recognized Expert | Platinum Partner

Hi @hannah_andrews,

 

Interesting. We have several sites running on WordPress with the HubSpot plugin and have not run into this issue. I assume WP and your plugins are all up-to-date? Were any other plugins added at this time? Potentially in a spam folder? Also, are you using the default WordPress comment moderation tool or a separate plugin such as Askimet?

 

Thanks for the ping @PamCotton!




Did this post help solve your problem? If so, please mark it as a solution.

Josh Curcio

HubSpot support and inbound marketing for OEMs, contract manufacturers, and industrial suppliers.
HubSpot Platinum Partner & HubSpot Certified Trainer

hannah_andrews
Member

Hi Josh,

 

Thanks for your reply! Everything is up to date right now. The only other plugin that we've added in the past 8 months since I've been here is "Updraft Plus - Backup/Restore", I believe HubSpot recommended that before adding the HubSpot plugin for the live chat feature.

I just checked the spam folder (and all other folders) for the comments, and it's not there either.

It looks like we have the Askimet Anti-Spam plugin and the Ajaxed Comments plugin. Those are the only two I see that explicitly mention comments.

0 Upvotes
Josh
Recognized Expert | Platinum Partner

Hi @hannah_andrews,

 

My first suggestion would be to test deactivating the HubSpot plugin and submitting a test comment and seeing if the comment notification comes through. Then do the same with Askimet and Ajaxify plugins. It will be best to start by testing with only one at a time deactivated so you can determine where the conflict or issue starts.

 

If that doesn't solve it, it will require a deeper dive.

 

Note: this is just a recommendation as to what I'd do. Proceed with caution. I'm not looking to upset your web developers. 🙂

 

Josh 




Did this post help solve your problem? If so, please mark it as a solution.

Josh Curcio

HubSpot support and inbound marketing for OEMs, contract manufacturers, and industrial suppliers.
HubSpot Platinum Partner & HubSpot Certified Trainer

trevorjones71
Key Advisor

Hi @hannah_andrews,

 

Some good tips here from @Josh.  Silly question, but have you checked Discussion Settings in Wordpress to see if something is unchecked?   In particular, I think you might want to make sure these are checked:

 

screenshot-www-otelco-com-wp-admin-options-discussion-php-1601556371530.png 

 

Hope this helps!

-Trevor

If my post resolves your issue, please accept my post as a solution.