Blog 'All Posts' Page is showing incorrectly.

SOLVE
Highlighted
Occasional Contributor

Hi everyone!

 

So my blog is live and published and I clicked on the 'All Posts' button at the bottom of my template and the page looks like this:

 

Screen Shot 2019-06-28 at 11.29.56.png

The link to this page is here.

 

I've had a look and I can't figure out any way to edit this page in the design tools section of Hubspot and I could really use some help. 

 

All the best,

 

Kayleigh

Reply
0 Upvotes
1 Accepted solution

Accepted Solutions
Highlighted
Advisor | Platinum Partner

OK. Great. This is the code that outputs all of your linked blog titles on the "All blog posts" page:

 

 

Screen Shot 2019-07-02 at 11.39.48.png

 

It looks like you might have a stray closing </div> which could be the cause of the broken layout.

 

Trying deleting the following </div> from your code (the </div> on line 58 only), "Publish changes" and let me know if the layout looks better (you can always put that </div> back into the code if this doesn't do the trick.)

 

 

Screen Shot 2019-07-02 div del.png

 

 

 


Did my post help answer your query? Help the Community by marking it as a solution.

Matthew Shepherd

An Inbound Growth Agency
Platinum HubSpot Partner

9 Replies 9
Highlighted
Advisor | Platinum Partner

Hi @JCMO_Kayleigh 

 

This article will help you edit your Blog Listing Template.


Did my post help answer your query? Help the Community by marking it as a solution.

Matthew Shepherd

An Inbound Growth Agency
Platinum HubSpot Partner

Reply
0 Upvotes
Highlighted
Occasional Contributor

Thank you for sharing this article with me! Unfortunately, it hasn't really helped as the listing template is blank and it doesn't allow me to preview anything either. If I just need to add code - does anyone have any suggestions or templates I can work from as I'm still learning.

 

Screen Shot 2019-07-02 at 09.05.30.png

 

All the best,

 

Kayleigh

 

Reply
0 Upvotes
Highlighted
Advisor | Platinum Partner

Hi @JCMO_Kayleigh 

 

Another approach to get to your blog listing template is to visit the blog listing page on your site while signed into your Hubspot portal, you should see a Hubspot icon floating in the top right of the screen, click that and then click "Edit Blog Template". Let me know if that shows you your template code.

 

hs-blog template.PNG


Did my post help answer your query? Help the Community by marking it as a solution.

Matthew Shepherd

An Inbound Growth Agency
Platinum HubSpot Partner

Reply
0 Upvotes
Highlighted
Occasional Contributor

Hi Matthew,

 

I did as you said and went to the 'All Blog Posts' page and clicked the hovering Hubspot Icon but it took me to the blog post view.  It shows me the template listing code but it shows me the code for our blog home page and not the 'All Blog Posts' page that I'm trying to edit.

 

Sorry if I'm completely missing something here!

 

All the best,

 

Kayleigh

Reply
0 Upvotes
Highlighted
Advisor | Platinum Partner

No problem @JCMO_Kayleigh it can just take a few tries to find the right section of the right template. Could you send a link to this All blog posts listing page and a screenshot of the blog listing code that you are seeing?

 

I noticed from your earlier screenshot that you have a Hubspot Migrations theme folder. Did the Hubspot team recently migrate you to this blog template?

 

 

 


Did my post help answer your query? Help the Community by marking it as a solution.

Matthew Shepherd

An Inbound Growth Agency
Platinum HubSpot Partner

Reply
0 Upvotes
Highlighted
Occasional Contributor

Hi Matthew,

 

This is the link to our 'All Blog Posts' page: https://blog.thisisproven.com/blog/all

 

And this is the code I see when in Design Tools:

 

Screen Shot 2019-07-02 at 11.39.48.png

 

Not that I'm aware of. All of my blog templates are located in our Proven Blog folder:

 

Screen Shot 2019-07-02 at 11.43.02.png

 

I'm just hoping to get the links in a list with the background colour being consistent.

 

Thank you again for all the support!

 

All the best,

 

Kayleigh

 

Reply
0 Upvotes
Highlighted
Advisor | Platinum Partner

OK. Great. This is the code that outputs all of your linked blog titles on the "All blog posts" page:

 

 

Screen Shot 2019-07-02 at 11.39.48.png

 

It looks like you might have a stray closing </div> which could be the cause of the broken layout.

 

Trying deleting the following </div> from your code (the </div> on line 58 only), "Publish changes" and let me know if the layout looks better (you can always put that </div> back into the code if this doesn't do the trick.)

 

 

Screen Shot 2019-07-02 div del.png

 

 

 


Did my post help answer your query? Help the Community by marking it as a solution.

Matthew Shepherd

An Inbound Growth Agency
Platinum HubSpot Partner

Highlighted
Occasional Contributor

Thank you so much, Matthew!! That's done the trick and the blog 'all posts' page looks great! Thank you for sticking with me and helping resolve it!

 

Have a lovely day! 

Reply
0 Upvotes
Highlighted
Advisor | Platinum Partner

Excellent! Glad it's fixed. You are very welcome.


Did my post help answer your query? Help the Community by marking it as a solution.

Matthew Shepherd

An Inbound Growth Agency
Platinum HubSpot Partner