Some Facebook leads form are not imported

SOLVE
Highlighted
Occasional Contributor

HI,

 

I recently started using hubspot. I managed to integrate my facebook leads into hubspot and the import of last 90 days contact was succesfull.

 

New leads are not being imported in some forms which have custom fields. The custom fields are properties that exist in hubspot and the older contact which have those fields were imported without issues.

 

I used the facebook lead test tool and for one form which has only default fields the contact is sent without issues but for all the other forms with custom fields the contact is not being imported into hubspot.

 

The campaings and ads were created in facebook.

Integration is working partially so I think the issue lies with those custom fields, what should I do?

 

I've read this:

https://knowledge.hubspot.com/articles/kcs_article/reports/how-does-hubspot-map-to-facebook-lead-ads...

https://knowledge.hubspot.com/articles/kcs_article/reports/create-and-analyze-facebook-lead-ads-in-h...

Reply
0 Upvotes
1 Accepted solution

Accepted Solutions
Community Manager

Hi @Lucianken,

 

Does the form include the default Facebook email field? HubSpot will only accept submissions that include an email field, as that is how HubSpot deduplicates contacts.

 

If it does include the email field, can you send along screenshots showing that?

 

Thanks,
Jenny


Did my post help answer your query? Help the Community by marking it as a solution
Reply
0 Upvotes
5 Replies
Community Manager

Hi @Lucianken,

 

Do you mind sharing some screenshots of what you're seeing in Facebook for the custom fields vs. in HubSpot?

 

Additionally, this article discusses how HubSpot handles custom fields. This FAQ resource also touches upon custom fields.

 

Thanks,
Jenny


Did my post help answer your query? Help the Community by marking it as a solution
Reply
0 Upvotes
Occasional Contributor

Sure no problem,

 

here:

https://imgur.com/a/PGKiGKM

 

both fields are problematic, in the csv export from fb the field is called

vehículo_y_año

 

My current hypotesis is that there is a problem parsing "ñ" and "í" so I will try with a more restricted character set and report back in case it works.

Reply
0 Upvotes
Occasional Contributor

I made a new form with just one custom field with only english characters. Again I sent the lead with the lead test tool and it wasn't updated into hubspot.

Yet, the new custom field was automatically imported into hubspot without issues.

So the new form is being read properly but the leads aren't.

 

Reply
0 Upvotes
Community Manager

Hi @Lucianken,

 

Does the form include the default Facebook email field? HubSpot will only accept submissions that include an email field, as that is how HubSpot deduplicates contacts.

 

If it does include the email field, can you send along screenshots showing that?

 

Thanks,
Jenny


Did my post help answer your query? Help the Community by marking it as a solution
Reply
0 Upvotes
Occasional Contributor

that's the issue, thanks I will add the email field.