LinkedIn Form Ads do not track new contacts to existing campaign

Osnovyanenko
Contributor | Gold Partner

Hello!

 

While setting up LinkedIn Ads tracking, I've noticed there's a collision with a Campaign feature. Basically, HubSpot Campaign tracks the sources based on the UTM tags. So naturally, I name my LinkedIn Campaign the same as my HubSpot campaign.

 

HubSpot Campaign.png

 

LinkedIn Campaign.png

 

Turns out, HubSpot's auto-tracking sets up utm_campaign after the name of ad group. This creates a tracking fault where the campaign data is not correctly viewed.

 

Wrong UTM campaign.png

 

I think the problem is with HubSpot's organization of UTM tags. I understand that HubSpot universally uses utm_source for the exact name of the platform and utm_medium for the type of traffic. However, the ad platforms use UTM tags to differentiate between ad groups and their ads. That's why I can't name every LinkedIn Ad Group after my HubSpot campaign - I wouldn't be able to track the performance.

 

That's why I'm curious if anyone has found a workaround and if HubSpot wants to fix it.

0 Upvotes
1 Reply 1
Osnovyanenko
Contributor | Gold Partner

So I've read the knowledge base, and here I've found that I can manually edit the utm_campaign. So here's what I'm going to do then. I'll change the utm_campaign to my campaign group name and leave the rest as is. For performance tags, there are these properties: 

hsa_acc={accountid}
hsa_cam={campaigngroupid}
hsa_grp={campaignid}
hsa_ad={creative}

 

I'll keep this thread open for a while in case anyone wants to share their opinions.