Hubspot not connecting to Google Ads

SOLVE
Highlighted
New Contributor

Hubspot will not connect to my Google Ads Account. I keep receiving this message: 

Create a new Google ad account
You'll need to create a Google ad account. Once that's done you can connect it to HubSpot and start reporting on who converts on your ads.

I am linked to create a new account. I then sign in to my Google Ads account and nothing happens from here.

Hubspot GlitchHubspot Glitch

I have done the following with no results:

- Cleared my cache
- Signed out and signed back in

- Disconnected any ad blocker that I had

 

Please assist.

Reply
0 Upvotes
1 Accepted solution

Accepted Solutions
Highlighted
HubSpot Employee

Hi @Charl

 

Thank you for your response! 

 

I confirmed this is not a global issue on status.hubspot.com, where HubSpot provides updates on system operations.

 

Can you try: 

  • Turning any ad blockers off and then reconnecting
  • Clearing your cache and cookies and then reconnecting
  • Opening an incognito window and then reconnecting
  • Logging into HubSpot on a different browser and then reconnecting

If that doesn't change anything, can you please provide your Google Ads account number and account name?

 

Thanks,

Melinda | (She/Her)

Customer Support Specialist

7 Replies 7
Highlighted
HubSpot Employee

Hi @Charl

 

Thank you for the post in the Community. 

 

Can you please reach out to HubSpot Support about this issue so we can get details about your HubSpot and Google Ads account?

 

There are a few requirements  for setting up your Google ads account which might help narrow it down too! 

 

Thanks,

Melinda | (She/Her)

Customer Support Specialist

Highlighted
New Contributor

Hi Melinda, 

 

Thank you but I am not getting the help needed. 

Unfortunately, this issue has not been resolved. 

Can not invest any further if the platform is not working.

 

Kind regards, 

Charl Swanepoel

Reply
0 Upvotes
Highlighted
HubSpot Employee

Hi @Charl

 

Thank you for your response! 

 

I confirmed this is not a global issue on status.hubspot.com, where HubSpot provides updates on system operations.

 

Can you try: 

  • Turning any ad blockers off and then reconnecting
  • Clearing your cache and cookies and then reconnecting
  • Opening an incognito window and then reconnecting
  • Logging into HubSpot on a different browser and then reconnecting

If that doesn't change anything, can you please provide your Google Ads account number and account name?

 

Thanks,

Melinda | (She/Her)

Customer Support Specialist

Highlighted
New Contributor

Hi Melinda, 

 

Thank you for your assistance. I am not sure what caused the problem, there is no adblocker active on Chrome. But Incognito mode seemed to have helped fix the issue. 

 

I can now start to run campaigns.

 

Thank you! 

Reply
0 Upvotes
Highlighted
HubSpot Employee

Hi @Charl

 

I'm so glad to hear you were able to get it working!

 

Happy HubSpotting!

 

Thanks,

Melinda | (She/Her)

Customer Support Specialist

 

Reply
0 Upvotes
Highlighted
New Member
Nice
Reply
0 Upvotes
Highlighted
HubSpot Employee

Hi @Charl ,

 

Thanks for reaching out and I'm sorry to hear you're running into issues connecting your Google ad account. Could you please check to see if your Google account is in smart mode. If it is you will need to switch it to Expert mode for it to be connected to HubSpot.

 

https://support.google.com/google-ads/answer/9520605?hl=en

 

Thank you,
Jason