Facebook Leads integration not working

Highlighted
Visitor

I've connected my Facebook Fan Page with Hubspot and everything seems to be OK but I don't get any contacts. However, I can see 11 Leads from the Facebook Business Manager, but here I only see "0" Contacts.

I created an ad here also to see if it would work like that but I have the same issue.

 

Can anyone help me?

Captura de pantalla 2018-10-23 a las 4.23.44 p.m..png

 

Reply
0 Upvotes
2 Replies
Community Manager

Hi @fzazzu,

 

If you are still experiencing this issue, can you please share more in regards to how you have this ad set up. 

 

Did you create the ad in Facebok or HubSpot? To start, can you please ensure your ad meets the criteria outlined here.

 

For additional troubleshooting and FAQs around Facebook lead ads, I wanted to share this article

 

If you are still stuck after taking a look at those, can provide additional screenshots in regards to what you are seeing in Facebook vs. HubSpot, what acount you have connected, and what information you are seeing in both platforms, that would be great.


Did my post help answer your query? Help the Community by marking it as a solution
Reply
0 Upvotes
HubSpot Employee

Hi @fzazzu,

 

If you are still experiencing this issue it would be helpful to have more information regarding this ad. It would be helpful to know when this ad was created and when you connected your Facebook account to HubSpot.

 

For additional context, when you connected your Facebook account to HubSpot we would have synced all of the leads you captured from Lead Generation ads within the last 90 days to your CRM. However, we are unable to attribute those leads to specific ads within HubSpot. All new leads going forward should be correctly attributed.

 

If you are still seeing issues with this please let us know.

 

Thank you,

Jason

Reply
0 Upvotes