Adwords doesn't link to subdomain

Occasional Contributor

Hi all!

 

We are facing a big issue here Smiley Sad, hoping someone can help us understand what to d!  We have a CPC Adwords campaign running, to promote our blog, which as you know we have build on a subdomain in order to have it in Hubspot (which is problematic for our SEO, but that's another concern). 

Well, so the campaign is running and Adwords seems to dislike the subdomain www.blog.xxx.com

So, what Adwords does is ignore the / blog. / and lead all traffic to /xxx.com/ . Which is not at all our intention! Hence, we are inable to promote our blog through Adwords!!

 

Did this happen to any of you? Anyone knows what we can do? 

 

Thanks in advance!

 

Best regards!

Daisy

4 Replies
Community Manager

Hi @DaisyDKroon,

 

Is your blog hosted by HubSpot? Are you using the HubSpot Ads tool? 

 

If not, I would recommend working with whoever set up your blog and ads to see if they added any parameters that could cause this. 

 

Thank you,
Jenny


Did my post help answer your query? Help the Community by marking it as a solution
Reply
0 Upvotes
Occasional Contributor

Hi @jennysowyrda

 

Thanks for your reply! Yes our blog is hosted by Hubspot, and no we don't use the Hubspot Ads tool as it is very limited, as an agency we prefer using Google Ads platform. We control both the Hubspot platform and our Ad platform. Does using the official Ad Platform makes it impossible to link to the subdomain? That would be really strange.

 

Thanks in advance for your help.

Daisy

Reply
0 Upvotes
Community Manager

Hi @DaisyDKroon,

 

No, using the ads tool in HubSpot doesn't make this possible. 


If the ad wasn't created in HubSpot, there is not much from the HubSpot side of things to look into. Have you tried searching the Google Ads community

 

Thanks,
Jenny


Did my post help answer your query? Help the Community by marking it as a solution
Reply
0 Upvotes
Occasional Contributor

Hi @jennysowyrda ,

 

Yes we are also looking into this issue on the Google marketing forums. But I just wanted to know, if this is the first time this happens with a Hubspot subdomain? Does Hubspot has records of this error ocurring anytime earlier?

As you know it's important to drive traffic to our blogs, and in this case (a the new website, with no social media) Adwords is our only way (apart from organic through content). So that makes it's crucial for us to get this solved asap. 

If you have any solution on Hubspots side that would be really appreciated! 

 

thanks in advance!

Best regards,

Daisy

Reply
0 Upvotes