Account & Settings

donrua
Contributeur de premier rang

how to stop KB from using http rather than https

SOLVE

We are getting dupe content, titles, etc for http version of KB articles in addition to https version.
When I look at source code, both the canonical, and where images are being stored, etc, seem to be using http.

We use https for all of our domains, for www.domain, for blog.domain, web.domain, etc. Why isn't it setting the canonical at https for the knowledge base articles? How do I fix this? I don't see the canonical option in Settings, nor have seen access to modify the KB template.

I don't want more and more pages created for KB all with building up http links throughout. And I'd like our KB to be indexed, and want to avoid dupe page issues.

0 Upvotes
1 Accepted solution
donrua
Solution
Contributeur de premier rang

how to stop KB from using http rather than https

SOLVE

I believe I found the answer. Our domain security settings were set to "require https" for all of our subdomains except learn.domain. I believe if I fix that, it probably will result in https being used for the canonical, og:image, etc.

 

donrua_1-1638202982596.png

 

View solution in original post

0 Upvotes
1 Reply 1
donrua
Solution
Contributeur de premier rang

how to stop KB from using http rather than https

SOLVE

I believe I found the answer. Our domain security settings were set to "require https" for all of our subdomains except learn.domain. I believe if I fix that, it probably will result in https being used for the canonical, og:image, etc.

 

donrua_1-1638202982596.png

 

0 Upvotes