Team Members didn't get the invitation mails

decorlab
Participant

I've seen there are many users that have the same issue but nothing could help me out to make it wor properly. I was trying to add team Members to the Hubspot but the invites are all pending. Also several resend invitations didn't get to the Team Members. (Also tried all the possible solutions like withelist ecc ecc.)

 

Is there any other way to garantee the access for other Memebrs?

4 Replies 4
MatthewShepherd
HubSpot Employee

Hi @decorlab 

 

Did you work through all of the steps in this post? https://community.hubspot.com/t5/Account-Settings/New-user-not-receiving-welcome-email-PLEASE-READ-B...

If steps 1 to 4 in that post aren't working, then we can ping one of the moderators - they'll want to know the following (probably best shared in a direct message):

1. Email address of the user

2. Portal you are trying to add the user to

3. Confirm where in the process the user is getting stuck


Matthew Shepherd

Senior Inbound Consultant

Professional Services | HubSpot

He/Him

linkedin.com/in/matthewshepherd/
https://www.hubspot.com/services/professional
decorlab
Participant

Yes i already tried all of this steps but nothing worked unfortunately. Oh where i can find some moderators to send a direct message?

0 Upvotes
MatthewShepherd
HubSpot Employee

@sharonlicari  or @jennysowyrda can you assist?


Matthew Shepherd

Senior Inbound Consultant

Professional Services | HubSpot

He/Him

linkedin.com/in/matthewshepherd/
https://www.hubspot.com/services/professional
jennysowyrda
Community Manager

Hi @decorlab,

 

I just direct messaged you with next steps! 

 

Thanks for the tag @MatthewShepherd!

 

Best,

Jenny

0 Upvotes