New user not receiving welcome email: PLEASE READ BEFORE POSTING

Highlighted
Community Manager

If you are adding users to your portal and they are not receiving the welcome email in their inbox, please ensure you follow the steps outlined below before posting: 

 

1. Check junk/spam folders

 

2. Verify the email address spelling is correct

 

3. Follow the steps outlined in this article

 

These steps include: 

Whitelisting the following email addresses: 

 

Whitelisting IP addresses (see in article

 

4. Resend the invitation 

You can do this within your portal by navigating into settings>users & teams>search for the specific user who has the pending invitation and resend the email. 

 

If you are still stuck after following those steps, please share: 

1. Email address of the user

2. Portal you are trying to add the user to

3. Confirm where in the process the user is getting stuck


Did my post help answer your query? Help the Community by marking it as a solution
8 Replies 8
Highlighted
Occasional Contributor

Hi, 

I have the same issue with adding jim.gilbert to the crm, sales & marketing hub. The invite doesn't arrive to his mailbox.
I tried whitelisting as well but it doesn't work, could you check what happened?

Benjamin

Reply
0 Upvotes
Highlighted
Community Manager

Hi @WTBurgess,

 

If you are still experiencing this issue can you please direct message me the information requested above? 

 

Thank you,
Jenny


Did my post help answer your query? Help the Community by marking it as a solution
Reply
0 Upvotes
Occasional Contributor

Hi

 

I have the same issue:

 

I have set up four users already, three using the godaddy email that I have created for them as new users for a new company.  Now the fifth user - also on the same godaddy email domain - has been setup, but no invite email recieved. 

 

FYI: so far I have - 

Deleted and recreated the user account in hubspot

Checked deleted and spam folders in the outlook.com client

Added the five hubspot smail addresses as recommended into the whitelist

 

I have not been able to add the IP as I don't see a way to get to that level from within the outlook.com client.

 

Given that for three other users set up this way (same hubspot, same email domain) all have been fine, I am finding it hard to see what would be different in this case.

 

Any Ideas?

Ken

Reply
0 Upvotes
Highlighted
Community Manager

Hi @kenhickling62,

 

I have reached out to you directly with next steps.

 

Thank you,

Jenny


Did my post help answer your query? Help the Community by marking it as a solution
Highlighted
New Member

Hi i have done all the above whitelisted and checked my e-mails but hes still not recieved an email with his invitation.

Reply
0 Upvotes
Highlighted
Community Manager

Hi @guyricha,

 

Can you please direct message me the email address for the user you are having issues with?

 

Thank you,
Jenny


Did my post help answer your query? Help the Community by marking it as a solution
Reply
0 Upvotes
Highlighted
New Contributor

Hello,

 

I am having the same issues --- I am adding a new member and they are not receiving the email invite to joing our hubspot profile. Checked their spam etc. No luck.

 

Can you assist?

Reply
0 Upvotes
Highlighted
Community Manager

Hi @Pasquars36,

 

Can you please direct message me the email address in question and I can investigate this further? 

 

Thank you,
Jenny


Did my post help answer your query? Help the Community by marking it as a solution
Reply
0 Upvotes