Live chat not showing on my wordpress site

SOLVE
Highlighted
Occasional Contributor

I installed the Word Press hubspot plugin to my word press site, and following the installation instructions posted below:

 

Search

The easiest way to install this plugin is to use the WordPress Admin interface.

Go to your admin dashboard
Find the “Plugins” menu
Click on “Add New”
Search for “HubSpot”
Click “Install Now”
Go to your “Plugins” menu
Click “Activate” on the HubSpot Form Builder plugin
Log in or sign up for a HubSpot account
Your WordPress site and HubSpot account will be connected and you’re ready to get started with HubSpot’s Conversion Tools.

 

When I refresh my site, the chat icon does not appear in the bottom right. Not sure what I need to do. I have uninstalled and Re-Installed.

 

the site I'm working with is https://wrenhealthcare.co.uk/ 

 

I'm using elementor PRO as the main theme/page builder for my site...I don't use a standard wordpress theme.

 

As you'll see below the chat button does appear when I'm editing the CSS under appearance>edit CSS in wordpress however, when you go to the live site it doesn't show. For now I'm using Purechat plugin and before you ask, yes I've disabled the plugin and the hubspot chat still doesn't show.

 

Any ideas what to do next? I've literally tried everything and read all the forums.

 

thanks,

 

Matt

screenshot5.PNGscreenshot3.PNG

screenshot1.PNGscreenshot2.PNGscreenshot3.PNGscreenshot4.PNG

 

Reply
0 Upvotes
1 Accepted solution

Accepted Solutions
Occasional Contributor

Hi Will,

 

I've managed to do it simply by clearing my cache with my caching plugin on wordpress. so it's sorted now! 

 

Thanks,

 

Matt

Reply
0 Upvotes
4 Replies 4
Highlighted
Esteemed Contributor | Platinum Partner

HIi @mattrichardson 

 

Thank you for all the information here - very thorough. 

 

Quick question: have you created a chatflow?

 

Setting up live chat is a 2 step process:

1. Settings (which you've done)

2. Create a Chatflow: Conversations > Chatflow. Once the chatflow is set up, make sure you toggle it on. 

 

Chatflows.png

 

 

 

 

Here is a good knowledge document from HubSpot on how to do this.

 

I hope this helps. If it does, please mark it as a solution to help the community. 

Thank you. 

Will Smith
HubSpot Certified Trainer
Highlighted
Occasional Contributor

Hi Will,

 

Yes chat flow has been created but it still doesn't show. Could it be some CSS that's blocking it?

 

Thanks,

 

Matt

 

screenshot8.PNG

Reply
0 Upvotes
Occasional Contributor

Hi Will,

 

I've managed to do it simply by clearing my cache with my caching plugin on wordpress. so it's sorted now! 

 

Thanks,

 

Matt

Reply
0 Upvotes
Highlighted
Esteemed Contributor | Platinum Partner

@mattrichardson ,

 

I was looking into this earlier today. Of course - clearing the cache.

Glad it worked out. 

Thank you for the update!

Will Smith
HubSpot Certified Trainer
Reply
0 Upvotes