Account & Settings

NiccoloParrini
Member

I am not receiving emails in the CRM

Hi,

I have configured my personal mailbox with IMAP service. The email works, if I send an email to a customer from the CRM he receives it and if he replies to me I can see the answer inside the CRM.

 

The problem is that if the customer writes to my mailbox first, I don't see the email inside the CRM. I saw that I need to set up an automatic forwarding of the mailbox to a specific hubspot address. I did it but it doesn't work.

 

The strange thing is that if I set the same email also in the "team email" section and put the email forwarding address that is requested, then the emails are correctly associated with the CRM customers.

 

The only problem is that this way my whole team sees the personal emails I receive, with notifications asking me to assign the conversation to someone.

 

How can I solve?

0 Upvotes
3 Replies 3
chrisworqflow
Key Advisor | Diamond Partner
Key Advisor | Diamond Partner

I am not receiving emails in the CRM

@NiccoloParrini  are you copying the correct forwarding address and not the BCC address in your email? 

 

I would recommend following the instruction in this article: https://knowledge.hubspot.com/settings/log-email-in-your-crm-with-the-bcc-or-forwarding-address

Christopher Barnett

Founder / CEO

Revenue Operations | WORQFLOW

mobilePhone
(832) 257-4192
emailAddress
christopher@worqflowmarketing.com
website
worqflowmarketing.com
address
17350 State Hwy 249, Ste 220 #6307, Houston, TX, 77064
NiccoloParrini
Member

I am not receiving emails in the CRM

I had found that guide a few days ago and I followed it before creating this ticket.

 

Unfortunately, doing that way I have the problems that I wrote above.

0 Upvotes
MiaSrebrnjak
Community Manager
Community Manager

I am not receiving emails in the CRM

Hi @NiccoloParrini

 

thank you for reaching out to the Community! The behaviour that you've described above is expected.

 

There are 2 different ways in which you can connect your inbox with HubSpot: 

  • Connect a personal email in Settings > General > Email. This allows you to send 1:1 emails from HubSpot and will also automatically log email replies - but only replies to emails that were previously sent from the CRM or sent from your inbox using the HubSpot Sales email extension or add-in.

It seems that you chose this connection first, but noticed that not all incoming emails are logging in the CRM. This is expected as I've mentioned above - if you receive a reply to an email that was not previously logged, or a new email from a contact, it won't log automatically. This way we make sure that sensitive personal emails don't get logged in the CRM automatically. The only way to log these incoming emails is to log them in HubSpot manually using your forwarding address, as @chrisworqflow mentioned above (thanks Chris!). 

 

  • Connect an inbox as a team email in the tool Conversations or in Settings > Tools > Inbox. A team email is a shared email address that multiple users have access to and use to communicate with customers. If you connect an inbox in Conversations (a native integration is only available for inboxes that are hosted with Office 365 or Google) or forward emails to a hosted email address in the conversations inbox, all incoming emails will get forwarded to HubSpot and will be visible to all users who have access to the Conversations inbox. Forwarding emails to a hosted email address in the Conversations inbox is different from using the HubSpot forwarding address. The hosted email address usually looks like this: [username]@[subdomain].hubspot.inbox.com.

 

It seems that a team inbox is not what you're looking for, as you don't want other users to have access to all of your emails. I'd therefore recommend to:

This forwarding address is intended to log specific emails, as opposed to being used for a general forwarding rule. As a result, we do not have support for adding a forwarding rule with the HubSpot forwarding address (most email clients require a verification code to set up forwarding). The only workaround we can provide is to set this forwarding up using an email client that does not require a verification code. 

 

I hope this helps!

 

Cheers
Mia, Community Team

 

 


Wusstest du, dass es auch eine DACH-Community gibt?
Nimm an regionalen Unterhaltungen teil, indem du deine Spracheinstellungen änderst


Did you know that the Community is available in other languages?
Join regional conversations by
changing your language settings