Hola! ¡Tenemos nuestra Comunidad en Español!

HTML email signature

New Member

Entered HTML code to email signature option but it does not show the actual email signature. Is anyone else having this issue? Tried to call customer service and we couldnt figure out a solution. 

Reply
0 Upvotes
7 Replies 7
Regular Advisor | Gold Partner | HubSpot Certified Trainer

Hi @abel415,

 

This functionality is working fine for me. I have tried across a few different accounts without issue. I would suggest trying to clear your browser's cache/cookies. That fixes a surprising number of weird issues.

 

Also, you're probably already doing this, but just in case, be sure that you've selected the "HTML" option vs simple option.

 

If that doesn't work, let me know. 




Did this post help solve your problem? If so, please mark it as a solution.

Josh Curcio

We help tier 1 & 2 manufacturers generate leads!
HubSpot Gold Partner & HubSpot Certified Trainer

New Contributor

I am having a similar issue where it won't let me save my custom HTML signature. It tells me I have unsupported HTML. To remove any <style> or <script> even though I don't have either one in the signature. Any thoughts.

Reply
0 Upvotes
Regular Advisor | Gold Partner | HubSpot Certified Trainer

@Rob_Allegra ,

 

Can you private message me your HTML code?




Did this post help solve your problem? If so, please mark it as a solution.

Josh Curcio

We help tier 1 & 2 manufacturers generate leads!
HubSpot Gold Partner & HubSpot Certified Trainer

Reply
0 Upvotes
Regular Advisor | Gold Partner | HubSpot Certified Trainer

It appears as though there is a rogue style tag buried in the signature HTML. Removing the style tag should allow you to save. I have tested on my side and the save option appears again. I have sent this to you in a private message.

 

If this works, please accept as a solution. Smiley Happy




Did this post help solve your problem? If so, please mark it as a solution.

Josh Curcio

We help tier 1 & 2 manufacturers generate leads!
HubSpot Gold Partner & HubSpot Certified Trainer

Reply
0 Upvotes
New Member

Hi there,

 

I'm also having the same issue with my email signature; Hubspot tells me that my signature has unsupported HTML. What's strange is that when I set my signature 6-months ago I didn't have any trouble.

 

Here is the HTML:

 

<!doctype html>
<style>
@import url('https://fonts.googleapis.com/css?family=Work+Sans');

h1 {
font-family: 'Work Sans', sans-serif;
font-size: 24px;
margin: 0 0 5px 0;
padding: 0;
}

p {
font-family: 'Work Sans', sans-serif;
margin: 0 0 2px 0;
padding: 0;
}

.link-image {
text-decoration: none;
height: 24px;
width: 24px;
margin: 0 6px 0 0;
padding: 0;
}

#title {
font-weight: bold;
color: #bf3c27;
}

#social_links {
margin: 15px 0 0 0;
}

#ca_logo {
float: left;
height: 160px;
width: auto;
margin: 0 20px 0 0;
}

#ca_logo_quote {
margin: 10px 0 0 0;
width: 210px
}
</style>

<img id="ca_logo" src="https://drive.google.com/uc?id=1837ShsbJHq6B-je5vcG43c9c9ufoc_Ix" alt="Code Avengers logo">

<h1>Damon Khan</h1>
<p id="title">Education Consultant
<p id="phone_number"><b>P:</b> (64) 027 366 8783
<p id="email"><b>E:</b> <a href="mailto:damon@codeavengers.com">damon@codeavengers.com</a>
<p id="website"><b>W:</b> <a href="www.codeavengers.com">www.codeavengers.com</a>

<p id="social_links">
<a href="https://www.facebook.com/CodeAvengers/"><img class="link-image" style="width=24px;height=24px;" src="https://drive.google.com/uc?id=1qy20q8JwqOoScH8Zv0doy0oRe9rB8Jso" alt="facebook link"></a>
<a href="https://twitter.com/codeavengers?lang=en"><img class="link-image" style="width=24px;height=24px;" src="https://drive.google.com/uc?id=1gdeHJ51W_gPleNSEP4RiMprGawcXGGk_" alt="twitter link"></a>
<a href="https://nz.linkedin.com/company/code-avengers"><img class="link-image" style="width=24px;height=24px;" src="https://drive.google.com/uc?id=1ZePGYcA22kxAEKJ-rF141FmBpY4KHTjR" alt="linkedIn link"></a>

<p id="p06"><img id="ca_logo_quote" src="https://drive.google.com/uc?id=1nwURRhrBK34ShGwPi5LGxLdUKst5TrPW" alt="Code Avengers text logo">

Reply
0 Upvotes
Occasional Contributor

I'm getting the same error...! I have had my signature set for 12 months and when i try and update it now it wont let me save it because it says that there is unsupported HTML (<script> <style>)

Has something changed recently?

Reply
0 Upvotes
Highlighted
Occasional Contributor

I just worked it out... I used this site - https://htmlg.com/html-editor/ to copy my code and then hit the "clean" button. It removed the style and script tags (along with the colours...) but i coloured the text back and copied the new code in and it let me save it. Smiley Happy