Domain & URL Link Missing on Settings

Highlighted
Occasional Contributor

I am trying to change my primary domain and every help article I see references a Domain and URL link on the settings page. I do not have that link and I can't find a way to make this change. My company changed domains from @therisebusiness to @risenowpayments and we've updated our email addresses, etc. but the account still is associated with our old domain. Please help. Thank you!

11 Replies 11
Highlighted
Community Manager

Hi @stacycs,

 

If you aren't seeing the domain and url settings within your settings, you may not have proper permissions to view that part of the portal. I would recommend reaching out to your super admin to check your permissions.

 

Additionally, if your website is hosted by HubSpot you should have access to HubSpot Technical Support. They should be able to assist you with this matter as well.


We are excited to announce that the Community will be launching a weekly newsletter on November 2, 2020!
Sign up today!
0 Upvotes
Highlighted
Occasional Contributor
I am a super admin.
Highlighted
Occasional Contributor

And my website is not hosted with you all. So not sure where to go from here.

Highlighted
Occasional Contributor

I have the same issue and I am also a Super Admin.

Highlighted
Community Manager

Hi @Bweber,

 

I would recommend connecting with Technical Support to talk through this matter.

 

Thank you,
Jenny


We are excited to announce that the Community will be launching a weekly newsletter on November 2, 2020!
Sign up today!
0 Upvotes
Highlighted
New Member

I'm having the same issue with the Domain & URL missing, but I am not a paying customer currently.  Am I able to still get some assitance?

Highlighted
Community Manager

Hi @wadewyant,

 

Can you confirm you are trying to update the information outlined here? If so, can you please send along screenshots of what you are seeing in your account when you look for this? Additionally can you please confirm all users in your account are seeing this?

 

Thank you,
Jenny


We are excited to announce that the Community will be launching a weekly newsletter on November 2, 2020!
Sign up today!
0 Upvotes
Highlighted
New Member

Following structions here:

https://knowledge.hubspot.com/cos-general/connect-a-domain-to-hubspot

 

"In the left sidebar menu, navigate to Domains & URLs."

 

Screenshot of my left sidebar menu attached. It appears to list items from A-Z so I assume it should appear between "Cookies" and "Import & Export". However I did scroll down and look in the entire menu just in case.

Screen Shot 2020-04-19 at 9.58.12 AM.png

0 Upvotes
Highlighted
New Contributor

Folks, it looks like you have to have a paid account to have that link in your settings.

@hubspot, we need a way to do email authentication, and the current documentation sends us to a link we can no longer access (I've been to it before!).

 

From my free account I have looked at the whole thing and not found it. I thought I needed to change my domain to update DKIM email authentication.

 

I'm Super Admin on this free HubSpot account, though I also Super Admin 2 other accounts. I found the link on a paid account, then tried it with my free account ID# and I get a permissions error page.

https://app.hubspot.com/domains/#######

hs.png

Highlighted
New Contributor

Dang. I guess all my emails on the free version will look spammy because they say "Gmail couldn't verify that [domain name] actually sent this message." At least that's what it's doing for me now. Poor experience.

0 Upvotes
Highlighted
New Contributor

Did this ever get resolved? Is it because we're using the free version of HubSpot?