Default Home Page not working

Highlighted
New Contributor

I have set my default home page to 'Deals' (in the drop down menu. From Settings -> Basic Info -> Default Home Page). However, when I log into Hubspot, I land on the Dashboards page. Am I missing something or is this a bug in Hubspot? 


Reply
0 Upvotes
5 Replies 5
Highlighted
HubSpot Employee

Good afternoon, 

 

Just ran a test in my own portal and the default page did update after a few minutes. 

 

Some things you can try: 

 

  • Try logging out and back into your HubSpot account, then try clicking the sprocket icon again, is the same observed?
  • Try clearing your browser cache then try clicking the sprocket icon again.

Let us know if this resolves the issue! 

Highlighted
New Contributor

Thanks for the quick reply. 

Logging out and clicking the sprocket icon takes me to the default page. That is good to know. 

However, I was wondering if there is a way to directly land on the default page on logging in. (which directs to apps.hubspot.com => which directs me to dashboards currently).  

Reply
0 Upvotes
Highlighted
New Contributor

I too have run into this same problem. I also tried changing the default back to desktop waited a few minutes then logged out. Then logged back in changed it to my default page for Contacts and after a few minutes logged out and logged back in all to no avail. 

 

Clicking on the sprocket works great but upon initial login it does not take me to Contact page like it used to.

Reply
0 Upvotes
Highlighted
HubSpot Employee

Hi both, 

 

The "default home page" setting works with the sprocket icon only as per the description below. I think the only workround for now is to use bookmarks on your browser. 

 

Default Home Page
Customize the sprocket icon sprocket in the top left corner of your account to navigate to a specific area of HubSpot. This will also be the page that loads when you log in to the account. Default home pages are set per user per account, so you can customize your home page in each account that you're a user in without affecting other users.

To set your default home page, click the Default Home Page dropdown menu, then select a product area. Your changes will automatically save, but may take a couple minutes to take effect.

 

Please do add this as an idea for our product teams to review. 

 

Have a great day! 

 

 

Highlighted
New Contributor

Before your last release this function worked and worked great but now I have to click on the sprocket, which is the same like having a bookmark (like you suggested). I will put in a request for this because that would be a nice feature set it and forget it, not be hasseled with it everytime.