Date/Time format bug

SOLVE
Highlighted
New Member

Hi team,

 

I have the date and time format set to "Australian" in the account settings (example date shown in this area is correct, format is DD/MM/YYYY)

 

Screen Shot 2018-06-26 at 17.01.57.png

 

When I create or modify tasks, the date is shown in the US format (MM/DD/YYYY). I'm not sure if this is elsewhere in the system as well, but I just noticed it as I was modifying a task a few minutes ago.

 

Screen Shot 2018-06-26 at 17.02.51.png

1 Accepted solution

Accepted Solutions
New Contributor

I actually found a fix for this about 2 months ago, but wanted to test it out for a while to be sure - all good so far! You need to change this for every user that has an email address added to your Hubspot account. Otherwise, you'll change yours and it'll be fine, but other users will still have the same issue as the system displays the data diffrently per user. And yes, this affects Sequences the same way etc...

 

To Resolve:
You need to click on your user icon in the very top-right of the Hubspot window (it either has your picture that you added, or a blank profile), and then click on Profile and Preferences. This opens you on the Basic Info page, where you can choose your Country (just below yoru Name and Lanugage). 

It automatically updates to the correct format now, but you use to be able to mix and match. So now if you select United Kingdom it atomatically gives you the following Format: 5 November 2018, 05/11/2018, and 1,234.56

Great new little fix, but still odd how it works, thanks Hubspot Smiley Happy

7 Replies 7
Highlighted
New Contributor

I have the same issue, despte changing the format in Account Defaults. I've tried changing this to US, and back to UK but no diffrence. 

 

All my Deal Close Dates, Tasks and everything else are in US format - confusing as **bleep** to look at a quick glance. Smiley Sad

Reply
0 Upvotes
Highlighted
New Contributor

Hi, we're facing the same problem. We switched our timezone in Account Settings to GMT but all contacts, tasks and updates are happening in IST. Is there a solution to solve this? 

Reply
0 Upvotes
Highlighted
Community Manager

Hi @Tanusha,

 

Some information in your portal will be dependent upon your computer's time zone settings. If you need to see elements in a different time zone, I would recommend changing your operating system's time zone as well.

 

Thanks,
Jenny


Did my post help answer your query? Help the Community by marking it as a solution
Reply
0 Upvotes
Highlighted
Occasional Contributor

I'm a new HubSpot user based in UK and I'm also having the same problem with my date format showing in US mm/dd/yy when it should be dd/mm/yy.  I've checked my operating system and the date format is showing correctly there.  I've tried to import one contact as a test but it came up with errors on the fields with dates in.  Any suggestions what I can do to solve the problem?

Reply
0 Upvotes
New Contributor

I actually found a fix for this about 2 months ago, but wanted to test it out for a while to be sure - all good so far! You need to change this for every user that has an email address added to your Hubspot account. Otherwise, you'll change yours and it'll be fine, but other users will still have the same issue as the system displays the data diffrently per user. And yes, this affects Sequences the same way etc...

 

To Resolve:
You need to click on your user icon in the very top-right of the Hubspot window (it either has your picture that you added, or a blank profile), and then click on Profile and Preferences. This opens you on the Basic Info page, where you can choose your Country (just below yoru Name and Lanugage). 

It automatically updates to the correct format now, but you use to be able to mix and match. So now if you select United Kingdom it atomatically gives you the following Format: 5 November 2018, 05/11/2018, and 1,234.56

Great new little fix, but still odd how it works, thanks Hubspot Smiley Happy

Highlighted
Occasional Contributor

Your a life saver.  It's worked.  Many thanks

Reply
0 Upvotes
Highlighted
New Contributor

 

Brilliant job! 

Reply
0 Upvotes