Wrong entry date when submitting contact data via API

Top Contributor

We submit data from a custom WP form via API.

 

The contact details are being collected fine, but for some reason the entry date is wrong, its adding a random entry date, usually about 4-5 weeks behind when the contact is being added. I can not work out why its doing this, as we're not sending that data, maybe an issue with the Hubspot plugin I'm not sure.

 

Any ideas?

Reply
0 Upvotes
4 Replies 4
HubSpot Employee

Hey @adiehl!

 

Could you please provide some more details on where this entry date is specified? Is this a property in your HubSpot portal or are you referring to the updatedat/createdat fields in the response when the form API runs?

Top Contributor

Thanks @doneill

 

this is a screenshot, does this help / answer the questions?

https://prnt.sc/uegl1s

 

Best,

Andreas

Reply
0 Upvotes
HubSpot Employee

Hey @adiehl!

 

Thanks for the image! This is the create date of a contact record. This is set by default when a contact is created inside of HubSpot. So it might not be the exact date the form was submitted however this is the date the Contact Record was created in your HubSpot portal. 

Reply
0 Upvotes
Top Contributor

Thanks. What sense does it make to use.a random different date rather than the date when the form was submitted? 

 

We used random e-mail addresses so we can exclude scenarios that we have used an e-mail which already had been assigned to a contact. 

 

To wrap it up: when we create a contact via the API the contact create data is a few weeks behind.

Reply
0 Upvotes