APIs & Integrations

EBurikov8
Member

Workflow extension

SOLVE

Hello,

 

I did all the steps for creating a workflow extension, also the post request with the example json but I cant seem to make the extension show up in the workflow Editor.

My App is also in the Connected apps and I tried different testing apps but it still did not work.

 

Does someone have an idea where I could look to see where the problem ist, like logs or something?

 

Best regards

 

0 Upvotes
1 Accepted solution
lindahl
Solution
Contributor | Diamond Partner
Contributor | Diamond Partner

Workflow extension

SOLVE

Hi @EBurikov8 ,

 

Can you please share us more information about the extension document you referring to? You can also share the sample code you're trying to create.

 

If you followed this, there should be no issue if you followed correctly.

However, if you are following this, the newer documentation and it is named as "custom workflow action" but not "workflow extension", I noticed that the sample code didn't mention anything at all about "published": true.  By adding that, it should show up in visually in workflow page.

 

{
  "actionUrl": "https://example.com/hubspot",
  "published": true,
}

 

You can also try an endpoint to fetch all and see if the one you created is listed.

Hope these helps!

View solution in original post

lindahl
Solution
Contributor | Diamond Partner
Contributor | Diamond Partner

Workflow extension

SOLVE

Hi @EBurikov8 ,

 

Can you please share us more information about the extension document you referring to? You can also share the sample code you're trying to create.

 

If you followed this, there should be no issue if you followed correctly.

However, if you are following this, the newer documentation and it is named as "custom workflow action" but not "workflow extension", I noticed that the sample code didn't mention anything at all about "published": true.  By adding that, it should show up in visually in workflow page.

 

{
  "actionUrl": "https://example.com/hubspot",
  "published": true,
}

 

You can also try an endpoint to fetch all and see if the one you created is listed.

Hope these helps!

EBurikov8
Member

Workflow extension

SOLVE

Hi @lindahl 

This helped 😄
I actually followed the "newer" documentation and the problem was the missing "published": true

I added the option in my POST request and then I got the workflows extension in my Workflow View.

 

This is how I added it - If someone has the same problem 🙂

EBurikov8_0-1652628600982.png

 

 

Thank you all for the fast help.

 

Best regards,

0 Upvotes
dennisedson
Community Manager
Community Manager

Workflow extension

SOLVE

@EBurikov8 ,

You will probably need to provide some more details before anyone can assist here.  Kind of flying blind at this point. 

@himanshurauthan or @zaklein may be able to help with more info 😀

Thanks,

Dennis




HubSpot Community Developer ShowMake sure to subscribe to our YouTube channel
where you can find the HubSpot Community Developer Show
0 Upvotes