Unable to update the price property when creating product via API

SOLVE
Highlighted
New Contributor

I've been trying to create a product via Products API and the product is created successfully and in the response i can the price and its value but the price property not is reflecting in HubSpot.

 

I'm using the default data set given by HubSpot here.

https://developers.hubspot.com/docs/methods/products/create-product

Reply
0 Upvotes
1 Accepted solution

Accepted Solutions
Community Manager

Hi @Shwetansh07,

 

Instead of price, can you use hs_price_usd

 

On my end, I'm able to see that hs_price_usd works just fine. 

Reply
0 Upvotes
4 Replies 4
Community Manager

Hi @Shwetansh07,

 

To get a full picture of thing, can you share over your:

- Portal ID

- The POST body that you send across

 

 

Reply
0 Upvotes
New Contributor

Hi @WendyGoh , Thanks for reaching out.

My Portal Id is - 6448908
I have setup Multi Currencies may be this could be a reason.

image.pngPOST data for Subscription Products
image.pngPOST data for one time charged product

Products are created Successfully.

 

image.pngBoth of these products have been created successfully but there are missing the price value

 

Price Value is Empty for both of the products.
image.png

Reply
0 Upvotes
Community Manager

Hi @Shwetansh07,

 

Instead of price, can you use hs_price_usd

 

On my end, I'm able to see that hs_price_usd works just fine. 

Reply
0 Upvotes
New Contributor

Thank you very much @WendyGoh 
Its working fine now Smiley Happy

Reply
0 Upvotes