Unable to complete OAuth with scope 'content' unless account has 'Super Admin' rights

SOLVE
Highlighted
New Contributor

I am trying to authorize my app and I have Admin with all (possible) rights/permissions enabled for my account (except Super Admin). The app is still my private app.

 

https://app.hubspot.com/oauth/authorize?client_id={blanked_out}&redirect_uri={blanked}&scope=content

 

AppID: 196760

HubID: 3862461

AcctLoginID: data-engineering@{same domain as this support account}

 

Can anyone confirm if Super Admin is absolutely required? (As a different test, I am able to authorize with scope 'contacts' with just Admin permission)

 

Any help would be MUCH APPRECIATED....!!!

 

Reply
0 Upvotes
2 Accepted solutions

Accepted Solutions
HubSpot Moderator

Hey, @ColinStewart.

 

It looks like you've doubly encoded scope=contacts%2520oauth. Can you try just with scope=contacts%20oauth?

Isaac Takushi

HubSpot Developer Support
Reply
0 Upvotes
Visitor

Hi @IsaacTakushi,

Yes that was the problem and it is now working correctly.  I copied the scope from the app setup page and didn't notice that it was already encoded.

 

Thanks for you help on this, much appreciated.

 

Colin.

10 Replies 10
HubSpot Moderator

Welcome, @lquach.

 

Happy to help.

 

The Super Admin role is not necessary, but users must have all permissions under the Marketing tab in SettingsUsers & Teams to approve integrations requiring the content scope.

 

Looking into account 3862461, I see that the "Data Engineering" user does not have Read or Write access to URL Redirects. See the screenshot below.

 

URL Redirects permission.jpg

 

These permissions are part of the content scope, so once you grant them to this user, you should be able to connect app 196760.

Isaac Takushi

HubSpot Developer Support
Reply
0 Upvotes
New Contributor

Hi Isaac,

 

Thanks you for your response.

 

I have enable the URL Redirects as you suggested, but unfortunately, the OAuth process still fails. After select the account to authorize, I just get this window and doesn't go any further. In normal case, I would expect the next screen to confirm what permission is being requested for the user to grant access.

 

Screen Shot 2019-06-27 at 11.07.00 AM.png

 

Any thoughts?

 

Laurance

Reply
0 Upvotes
Visitor

Hi,

I get the the 3 bouncing balls forever when I try to authorize, did you manage to resolve this?

In the browser console the following error is thrown:

HubSpot1.png

Reply
0 Upvotes
HubSpot Moderator

Hi, @lquach and @ColinStewart.

 

I'm actually seeing the same thing. Could you try encoding your redirect_uri parameter value?

 

For example, this query string format triggers the perpetual loading after selecting my account:

 

client_id=my_client_id&scope=contacts%20content%20forms&redirect_uri=https://www.mysite.com/validate

 

However this format causes a successful redirect:

 

client_id=my_client_id&scope=contacts%20content%20forms&redirect_uri=https%3A%2F%2Fwww.mysite.com%2Fvalidate

 

Let me know if the latter format works!

Isaac Takushi

HubSpot Developer Support
Reply
0 Upvotes
Visitor

Hi @IsaacTakushi,

Thanks for the reply.  I am already using your latter suggesion, so that doesn't help.

One other thing is that I'm using localhost for my redirect_uri as the webiste is only currently on my local machine, so my uri is:

redirect_uri=http%3A%2F%2Flocalhost%2Fapi%2Freply%2Fhubspot&state=companies%3A1&scope=contacts%2520oauth

 

Do you have any further suggestions?

 

Thanks.

Reply
0 Upvotes
HubSpot Moderator

Hey, @ColinStewart.

 

It looks like you've doubly encoded scope=contacts%2520oauth. Can you try just with scope=contacts%20oauth?

Isaac Takushi

HubSpot Developer Support
Reply
0 Upvotes
Visitor

Hi @IsaacTakushi,

Yes that was the problem and it is now working correctly.  I copied the scope from the app setup page and didn't notice that it was already encoded.

 

Thanks for you help on this, much appreciated.

 

Colin.

HubSpot Moderator

Glad I could help, @ColinStewart!

Isaac Takushi

HubSpot Developer Support
Reply
0 Upvotes
New Contributor

Hi Isaac,

 

Here is my exact URL string:

 

https://app.hubspot.com/oauth/authorize?client_id=my_client_id&redirect_uri=https%3A%2F%2Fwww.mycomp...

(my_client_id is my client id, and mycompany is my replaced with my real company name)

I just gave it a try and still seeing the circles....

I tried this last name, Jul 1 @ 9:49PM US-PST. Can you check the log?

 

Thanks

Laurance

Reply
0 Upvotes
HubSpot Moderator

Hi, @lquach.

 

I'm not able to easily access the log.

 

Can you direct message me with your full auth URL including an unredacted client_id and redirect_uri?

 

In my flow, I:

  1. Navigate to the URL.
  2. Select my account.
  3. Am redirected successfuly to the “Request for Integration Permissions” page.

Can you confirm that you are seeing the dots between steps 2 and 3?

Isaac Takushi

HubSpot Developer Support
Reply
0 Upvotes