UPDATE Engagement API

SOLVE
ASawant0
Member

Hi All,

 

Can someone please help me with below API

I am trying to change the assigned owner for TASK (ACTIVITY). But the assigned owner is showing invalid owner.

PATCH /engagements/v1/engagements/:engagementId

BODY -{    "engagement": {         "id": 14251938878,         "ownerId": 12510804     } }

The API output is without errors. But I am not seeing any change.

Please advise!

0 Upvotes
1 Accepted solution

Accepted Solutions
dennisedson
Solution
Community Manager

@ASawant0 , try removing the id from the body.

Like this

{
    "engagement": {
        "ownerId": 12510804
       }
}

You are already expressing the ID of the engagement in the uri so that does not need to be repeated in the body.  I just tested and it works for me.

Thanks,

Dennis




Check out our Community Developer Blog
where we feature our Community driven developer podcast and how to content

View solution in original post

4 Replies 4
MiaSrebrnjak
Community Manager

Hi @ASawant0,

 

Thank you for reaching out to the Community! 

 

I wanted to tag in a few experts: @DanielSanchez@RBThomas@LPM@MichaelC do you maybe have any tips or a possible solution for @ASawant0? Thank you!

 

Mia  


Wusstest du, dass es auch eine DACH-Community gibt?
Nimm an regionalen Unterhaltungen teil, indem du deine Spracheinstellungen änderst !


Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !


0 Upvotes
ASawant0
Member

Hi  @DanielSanchez@RBThomas@LPM@MichaelC

Please advise!

 

Thanks,

Ankita

0 Upvotes
dennisedson
Solution
Community Manager

@ASawant0 , try removing the id from the body.

Like this

{
    "engagement": {
        "ownerId": 12510804
       }
}

You are already expressing the ID of the engagement in the uri so that does not need to be repeated in the body.  I just tested and it works for me.

Thanks,

Dennis




Check out our Community Developer Blog
where we feature our Community driven developer podcast and how to content

View solution in original post

ASawant0
Member

Hi Dennis,

Thank you for the solution

Looks like something changed. Now I see task assigned to userids. But it should show emails attached to it. Please advise!

ASawant0_0-1628124689067.png

 

0 Upvotes