Trouble with endpoint url in webhook app

SOLVE
Highlighted
New Contributor

Hello,

 

We are trying to use an endpoint url in a webhook app, but we don't get a response on the endpoint server. We think that te problem is hiding in the use of ports in the url.

the url is: https://tst-b2b-api.achmea.nl:4443/ddd/commercialdevice/2019/01

Is there somebody with the same problem? Or is there another way to get this right?

 

All the help is welcome!

Reply
0 Upvotes
1 Accepted solution

Accepted Solutions
HubSpot Moderator

Hi, @Nordin.

 

Apologies for the delayed response.

 

We have added your root certificate, Staat der Nederlanden Root CA - G3, to the trust store platform webhooks use. Thanks for your patience.

 

Are you still encountering issues?

Isaac Takushi

HubSpot Developer Support
Reply
0 Upvotes
8 Replies 8
HubSpot Moderator

Welcome, @Nordin.

 

Are you referring to app 187894? If so, I see a count of successful webhook notifications here, but they didn't occur recently enough for me to see calls logged on this page.

 

Is the issue that HubSpot is reporting 200 responses from your endpoint but you're not seeing the payloads?

Isaac Takushi

HubSpot Developer Support
Reply
0 Upvotes
New Contributor

Hi Isaac,

 

Yes we had an other endpoint url that was working great, that are the 200 succesful events. With the new url we are gettimg the errors. Do you have some ideas of the problem?

Reply
0 Upvotes
HubSpot Moderator

Hi, @Nordin.

 

Thanks for clarifying. At this time, I'm not sure where the problem lies.

 

Would you mind enabling the lifecyclestage subscription again so that I can investigate the errors which appear on the MonitoringWebhooks page?

Isaac Takushi

HubSpot Developer Support
Reply
0 Upvotes
New Contributor

Hi Isaac,

 

I've enabled the app. Could you let me know if the port name in the url is the problem?

 

All the best,

 

Nordin 

Reply
0 Upvotes
HubSpot Moderator

Hey, @Nordin.

 

I'm still working to drill into that error on our end. Thanks for your patience.

 

Could you confirm the URL you used before which worked successfully?

Isaac Takushi

HubSpot Developer Support
Reply
0 Upvotes
HubSpot Moderator

Hi, @Nordin.

 

Apologies for the delayed response.

 

We're seeing an SSLHandshakeException error in our logs:

 

javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

 
Did you intend to use port 4443? I ask because it's oddly close to 443, which is usually used for SSL.

Isaac Takushi

HubSpot Developer Support
Reply
0 Upvotes
HubSpot Moderator

Hi, @Nordin.

 

I see you've connected with my colleague Brian. We are working with our internal team to see what can be done about your request.

 

Also, can you confirm you intended to use port 4443, perhaps as an alternative to the standard HTTPS/SSL web traffic port 443?

 

Thank you for your continued patience. I look forward to getting to the bottom of this!

Isaac Takushi

HubSpot Developer Support
Reply
0 Upvotes
HubSpot Moderator

Hi, @Nordin.

 

Apologies for the delayed response.

 

We have added your root certificate, Staat der Nederlanden Root CA - G3, to the trust store platform webhooks use. Thanks for your patience.

 

Are you still encountering issues?

Isaac Takushi

HubSpot Developer Support
Reply
0 Upvotes