Test form to trigger webhook

11bar
Member

Hi

I want to test various forms which trigger a webhook.

If I test the webhook with an existing contact the fields (constant values as hidden fields in this case) don’t get send with the webhook, probably because I use an existing contact which doesn’t contain those fields on the contact.

If I test the form in the form designer, the webhook isn’t triggered. I can test that the form works but it doesn’t trigger the webhook.

Is there an easy way to test a form including triggering the webhook?

Thanks
Mark

0 Upvotes
4 Replies 4
11bar
Member

The part with the field is resolved, for an existing contact the field wasn’t stored. I needed to create a new contact via a form, the test function didn’t create contacts so I had to put the form on a landing page first.

Remaining problem is that filling out the form isn’t triggering the webhook. I keep looking into this.

0 Upvotes
Derek_Gervais
HubSpot Employee

Hi @11bar,

Are you using the webhooks API or a webhook action in a workflow? If you’re using the webhooks API, there isn’t a form submission subscription. There are only contact creation and contact property update subscriptions. These can send webhook notifications when forms are submitted if it results in one of the subscribed actions (i.e. contact creation and/or property change) but it won’t send a webhook notification due to the form submission itself.

0 Upvotes
11bar
Member

Hi Derek

I use the webhook in a workflow and I setan Enrollment Trigger “Contact has filled out form xyz” and the next step is the actual webhook.

That should fir it automatically right?

Thanks
Mark

0 Upvotes
Derek_Gervais
HubSpot Employee

Hi @11bar,

Yes, that should fire whenever a contact is enrolled in the workflow. Depending on the workflow’s enrollment/re-enrollment/suppression settings, there might be some submissions that don’t trigger a webhook. Can you post a link to the workflow in question, and an example contact that should have triggered a webhook, but didn’t?

0 Upvotes