Salesforce integration - salesforce field not showing in hubspot mapping

Highlighted

hi i am trying to sync my campaign name and not campaign id to a custom field in hubspot. the salesforce field is not even showing in the mapping tool. i have set permissions to allow etc. does anyone know of a restriction based on field type that doesnt allow the field to show in the mapping tool?

Reply
0 Upvotes
5 Replies 5
Highlighted
HubSpot Employee

@Jonny_Katz It should show up under custom mappings in Contact. If you don’t see it there I would contact support as that might be a product issue.

Reply
0 Upvotes
Highlighted

they couldnt help…

Reply
0 Upvotes
Highlighted
Visitor

Was there ever a resolution to this? I'mn currently struggling with the same issue & support have been unable to fix

Reply
0 Upvotes
Highlighted
New Contributor

I had the same problem. You should check the field level security in Salesforce. Go to Setup->Object Manager-> your object (Lead or other) -> Fields and Relationships -> click on the field -> click on Set Field Level Security button -> make this visible for your integration user (e.g. if you use an admin account as the integration user in Hubspot you have to make the field visible to the admin profile).

Reply
0 Upvotes
Highlighted
New Contributor

Please check also https://knowledge.hubspot.com/salesforce/resolve-salesforce-integration-suspension-errors#salesforce...

And try refreshing the Hubspot mapping page. This solved the issue for me after I set the field-level security.

Reply
0 Upvotes