Resubscription email link not resubscribing

SOLVE
Regular Contributor

Morning,

 

I have a workflow which is triggered by my lambda making an HTTP POST request to the following API endpoint - 

/automation/v2/workflows/<workflow_id>/enrollments/contacts/<email_address>
 
This seems to work fine and triggers the workflow. The contact is enrolled in the workflow, which sends an email to the contact. The email contains the "link to subscription confirmation" .
The email is sent and received correctly. When the link in the email is clicked, the receipient is taken to a webpage, which shows the correct email address and says something like: "thanks, you have updated your preferences"
This page is created by Hubspot.

So, all the above is as expected. However, when I view the properties for the contact, s/he is still shown as opted out from email: Yes
 
What further do I need to do so that this field will be updated?

 

 

 

Regards

Jez D

Reply
0 Upvotes
1 Accepted solution

Accepted Solutions
Community Manager

Hi @Jez_D,

 

Thank you for providing me with the information.

 

In this case, when looking into your workflow 6497707 on portal 5956805, I noticed that the email test_subscription_email is also using the {{ subscription_confirmation_url }} token and as I mentioned on my initial response on this thread, this token set up for double opt in marketing email which you can learn more here: Set up double opt-in for emails.

 

When looking to resubscribe opt out contact, you should be using the resubscribe email (id: 12701252995) instead. So that contact can click the update preferences page to update their subscription type. 

Reply
0 Upvotes
4 Replies 4
Community Manager

Hi @Jez_D,

 

I hope all is well with you 😄

 

I would expect that if the contact check the type of communication emails that they'd like to receive in the subscription preference page, the contact property - opted out from email wouldn't be showing Yes

  • In this case, when looking into your portal 5474140, I was able to locate the test_resubscribe_email (if that's the one you're working on), and I noticed that you're using the {{ subscription_confirmation_url }} token. This token is set up for double opt in marketing email which you can learn more here: Set up double opt-in for emails
  • Looking at your settings, it doesn't seems that you've double opt in enabled and so I'd believe that you're looking to update contact marketing emails preferences without double opt in. In this case, you may to refer to this useful documentation: Resubscribe contacts to your marketing emails

I hope this helps to clarify and do let me know if I'm looking at the wrong workflow/email and if so, do you mind sharing with me the portal ID, workflow and contact in question?

Reply
0 Upvotes
Highlighted
Regular Contributor

@WendyGoh 

Thanks for the reply Wendy. 

The portal_id is 5956805

The workflow is 6497707

Reply
0 Upvotes
Community Manager

Hi @Jez_D,

 

Thank you for providing me with the information.

 

In this case, when looking into your workflow 6497707 on portal 5956805, I noticed that the email test_subscription_email is also using the {{ subscription_confirmation_url }} token and as I mentioned on my initial response on this thread, this token set up for double opt in marketing email which you can learn more here: Set up double opt-in for emails.

 

When looking to resubscribe opt out contact, you should be using the resubscribe email (id: 12701252995) instead. So that contact can click the update preferences page to update their subscription type. 

Reply
0 Upvotes
Regular Contributor

I changed my subscription link in the email to take the contact to the manage-preferences page. It works now. 

 

Thanks for your help

Reply
0 Upvotes