Problemas with chrome.identity.launchWebAuthFlow

SOLVE
Highlighted
Regular Contributor | Gold Partner

We are a Connect Partner and we developed a Chrome extension that uses chrome.identity.launchWebAuthFlow for authentication (not just for installing the app but for user authentication every time a user wants to use the app)

We experience a very strange behavior where the WebAuthFlow popup closes by itself ONLY on some (most) MacOS computers, during some specific times. The first time this happened was Friday 17th , it solved by itself with a "Authorization page could not be loaded" error, and today it's happening again.

 

This problem never impacted any user on Windows, it was verified on multiple versions of MacOS and Chrome (and on multiple differne countries), but for some reason it's not happening in HubSpot (support cant reproduce it, but when we do Zoom they were able to see it)

 

We are considering changing the whole authentication flow replacing the chrome.identity.launchWebAuthFlow with just a new tab in the browser and a "traditional" oauth flow (at least on MacOS computers) if this can't be solved.

 

1 Accepted solution

Accepted Solutions
HubSpot Moderator

Hi @Walter_g , I talked with Aidan, your support rep, and he'll respond to you asap. Since you're in the beta program for connect partners you can use the email alias for connect support to chat directly with our developer advocates. Aidan will send over that email address to you shortly.

Reply
0 Upvotes
1 Reply 1
HubSpot Moderator

Hi @Walter_g , I talked with Aidan, your support rep, and he'll respond to you asap. Since you're in the beta program for connect partners you can use the email alias for connect support to chat directly with our developer advocates. Aidan will send over that email address to you shortly.

Reply
0 Upvotes