Hola! ¡Tenemos nuestra Comunidad en Español!

Permission error 403 in Zapier

Occasional Contributor

API error says I don’t have permissions. We are a paid sales pro account.

DataPostError: Problem creating auth. (authorization failed: api.hubapi.com returned (403) Forbidden and said “This access_token (d5c30da1-bed2-4239-bdda-638a603ec220) does not have proper permissions! (requires any of [content-access])”)

It was working previously but recently stopped.

Reply
0 Upvotes
5 Replies 5
Occasional Contributor

@stilli What endpoint are you trying to get at? Do you have an example of the OAuth call where you request the scopes?

Reply
0 Upvotes
Highlighted
Occasional Contributor

This is a zapier integration trying to create a contact. I don’t have any more detail other than the error message.

Reply
0 Upvotes
Occasional Contributor

@stilli This might be better to reach out to Zapier then about the error as they have access to make any adjustments that are needed.

Reply
0 Upvotes
Community Manager

@stilli and @pmanca I think I see what’s going on. As a sales pro user, you don’t have access to the content tools in HubSpot (that’s basically what the error message is trying to say). The reason this is no longer working is because we recently started to check scopes on authorization instead of just when they actual request is made. You should look into using the HubSpot CRM (vs just HubSpot) Zap which shouldn’t be requesting the content scope.

If that’s the Zap you are already using, then we will need to have them request fewer scopes for the HubSpot CRM channel.

-Zack

Occasional Contributor

Thank you Zack, that appears to have been the issue. I recreated the Zap with Hubspot CRM instead of Hubspot and it worked.

Reply
0 Upvotes