Oauth token does not have proper permissions! (requires all of [form-analytics-api-access])

SOLVE
devForFer
Member

Hello.

 

I know a question of a similar type has been posted, but there are some differences.

 

I am getting this error ( Oauth token (xxx) does not have proper permissions! (requires all of [form-analytics-api-access]) ) for an account that should have those permissions (Marketing Pro).

Currently, I am trying to access the analytics report for forms, with Oauth. My purpose (for now) is retrieving the submissions per form for various forms, without an interest in the contents.

 

The portal ID is 4394779

Pricing tier: Marketing Pro

Endpoint:

url = f"https://api.hubapi.com/analytics/v2/reports/forms/monthly&start={start_date}&end={end_date}&f={form_id}"

Scopes: Oauth, Forms, Reports

 

Which, according to this (access to analytics reporting per tier)  should be available already

 

Thanks in advance

0 Upvotes
1 Accepted solution

Accepted Solutions
WendyGoh
Solution
HubSpot Employee

Hey @devForFer,

 

In this case, I believe portal 4394779 has the necessary scopes to call the Get Analytics data for specific objects endpoint. The issue seems to be that the app that is requesting to call the Get Analytics data for specific objects endpoint doesn't have the necessary scope (business-intelligence) granted.

 

As such, could you ensure that the app that is making the request has the business-intelligence granted on portal 4394779? 

View solution in original post

0 Upvotes
2 Replies 2
WendyGoh
Solution
HubSpot Employee

Hey @devForFer,

 

In this case, I believe portal 4394779 has the necessary scopes to call the Get Analytics data for specific objects endpoint. The issue seems to be that the app that is requesting to call the Get Analytics data for specific objects endpoint doesn't have the necessary scope (business-intelligence) granted.

 

As such, could you ensure that the app that is making the request has the business-intelligence granted on portal 4394779? 

View solution in original post

0 Upvotes
devForFer
Member

Hey,

 

That seems to have solved the issue. Thanks!

 

0 Upvotes