OAuth2.0 not redirecting to callback URL

lytboard
Member

I'm trying to fetch data from the APIs. For authentication I'm using OAuth2.0. 

 

  • client_id: XXXXXXXX
  • redirect_uri: https://localhost/hubspot_callback
  • scope: contacts,business-intelligence

After authenticating the account, the grant access popup is not showing up. The loader symbol is being shown and not being redirected to the redirect_uri. 

 

Is there something I'm missing? I tried it with multiple accounts, tried clearing cookies. But I'm stuck with the same error. 

 

0 Upvotes
4 Replies 4
himanshurauthan
Key Advisor | Platinum Partner

Hello @lytboard ,

 

Are you trying to authorize with the super-admin user? If not then I would recommend you to try once by super-admin user role. This will ensure that the person installing the integration has all of the required roles to approve the application.

 

Thanks

Digital Marketing & Inbound Expert In Growth Hacking Technology
0 Upvotes
lytboard
Member

@himanshurauthan I was logged in as a super admin. 

 

May be the issue was I started testing immediately after creating the app. 

 

After 10 hours, it started working fine, without having to make any changes in the code. 

HubBase
Member | Partner

Hi there,

 

I was working on developing a HubSpot application last week and encountered the same problem. The solution is to not use localhost in the redirect URI, use an address that is publically accessible.

 

Hope this helps.

 

Hubbase.io

0 Upvotes
lytboard
Member

@HubBase I used ngrok for the same reason as the redirect_uri wasnt accepting port number in the url. 

 

My redirect url was: https://localhost:3333/hubspot_callback. 

 

 

0 Upvotes