APIs & Integrations

DCorrea
メンバー

Newly created contact not returning (contact does not exist)

解決

Hi, the application I'm working on submits a form (https://api.hsforms.com/submissions/v3/integration/submit) and right after that it tries to get information for the newly created contact (https://api.hubapi.com/contacts/v1/contact/email/{email}/profile?hapikey={apiKey}). It usually works, but sometimes I get a "contact does not exist" message. When I find this message in the logs, I manually check the contact, and it's there, and I can successfully retrieve the information using the API.

 

So my question is: is it "expected" that Hubspot may need a second or 2 (or more) to be able to retrieve a contact created via a form submission? Maybe when the form API returns, it's still executing something asynchronously.

0 いいね!
1件の承認済みベストアンサー
dennisedson
解決策
HubSpot製品開発チーム
HubSpot製品開発チーム

Newly created contact not returning (contact does not exist)

解決

Hey @DCorrea 

Although it should be pretty quick, it will have to go through a dedupe process.  That might be what you are experiencing 🤔

元の投稿で解決策を見る

2件の返信
dennisedson
HubSpot製品開発チーム
HubSpot製品開発チーム

Newly created contact not returning (contact does not exist)

解決

Just a little follow up as I just saw something else with the same type of question.

Just going to quote directly

It should be within a couple of minutes. It’s hard to be specific because it’s possible there was a lot of import activity just prior that could back up indexing. I’ve seen it be as high as 30 minutes, but generally it’s under a minute.

 

Hope that gives  more complete answer

0 いいね!
dennisedson
解決策
HubSpot製品開発チーム
HubSpot製品開発チーム

Newly created contact not returning (contact does not exist)

解決

Hey @DCorrea 

Although it should be pretty quick, it will have to go through a dedupe process.  That might be what you are experiencing 🤔