Missing or invalid scopes error on token refresh

EVuorihovi
Member

Hi,

I'm getting the following error when attempting to refresh the authentication token for a specific account: 

{"status":"BAD_SCOPES","message":"missing or invalid scopes","correlationId":"805ff89c-1a8c-4eab-a112-6a24a68e2000"}

 

It worked perfectly fine a week ago and continues to work for other accounts and no changes have been made.

 

I've tried to reconnect the account and that isn't working anymore, giving the error:

Couldn’t complete the connection
This account doesn't have access to some HubSpot features that are required by this app. Please contact the app developer.

 

Thanks for your help.

5 Replies 5
dennisedson
Community Manager

@webdew 

Any chance you can help here 😀

Thanks,

Dennis




Check out our Community Developer Blog
where we feature our Community driven developer podcast and how to content
0 Upvotes
EVuorihovi
Member

@dennisedsonAny word on this? I'm still having problems.

Thanks!

0 Upvotes
dennisedson
Community Manager

@EVuorihovi 

Most likely the portal in question has changed their subscription level and does not have access to something your app is requesting. 

Thanks,

Dennis




Check out our Community Developer Blog
where we feature our Community driven developer podcast and how to content
0 Upvotes
EVuorihovi
Member

As far as I'm aware, the subscription level hasn't changed. I have tried changing the scopes (in many different permutations) on our app to get it to work but it still doesn't.

Would I be ok to DM you my app ID and scopes and the portal id in question?

Thanks

0 Upvotes
EVuorihovi
Member

@dennisedson Would I be ok to DM you my app ID and scopes and the portal id in question?