Issue with integration with Apollo

petertaiga
Participant

I have Hubspot synced to chargebee and apollo. Basically using to hand over all customer data between tools we use.  The first time I synced with Chargebee a set of custom properties (variables) were created in Hubspot that are marked as Single line text although some are in practice numerical. The strange thing is that Hubspot seems to treat these properties as numerical because if I use the filter function is gives me the options "Is greater than" "Is less than" etc.

 

The problem I have is that these properties (that are marked as Sigle line text but behave like numerical) are not recognized by Apollo if I try to sync them. In Apollo you can choose what type of property (variable) you want to sync from HubSpot and then a list of available variables appear. In Apollo these variables are not appearing not as numerical nor as Single line text. I don´t have issues with other variables only with the ones that behave as I have described. I belief the problem is created because HubSpot seems to be inconsistent in the treatment of properties.

 

Anybody seen this before or has an idea how to solve this?

0 Upvotes
2 Replies 2
dennisedson
Community Manager

hello @petertaiga , 

Could you provide some code examples of what you attempting to do?  Also, listing the API endpoints that you are employing would be great!

 The more information you provide, the better we can help!  

 

Thanks in advance!

 

 

Thanks,

Dennis



Check out our Community Developer Blog
where we feature our Community driven developer podcast and how to content
0 Upvotes
petertaiga
Participant

Hi Dennis, I have been using the integration of Chargebee, therefore I have no clue on API endpoints. What seems to be strange is that HubSpot has variables that are marked as "Single line text" but are treated as "Numerical". I believe the issue starts with the integrations with Chargebee, or in other words Chargebee creates new variables in HubSpot in a way that is not consistent. At the same time it is strange that HubSpot apperently facilitates this non consistent qualification of variales. So far I have not been able to find the source of the problem nor to solve it.

0 Upvotes