APIs & Integrations

CNM
Member | Diamond Partner
Member | Diamond Partner

Hubspot tracking code

We're currently facing a technical challenge and would appreciate any insights or solutions. Our client's website experiences (stripweb.be) stops loading whenever we activate the HubSpot tracking code through Google Tag Manager. Here’s the situation:

  • Issue: The website loads slowly and blocks specifically when the HubSpot tracking code is enabled.
  • Website setup: The site is built on a custom-made system and has functioned without issues until this problem began a month after initial setup.
  • Developer's Input: Our developer suggests that the crash may be due to the heavy load caused by numerous active fields used as filters in an e-commerce webshop. This load is conflicting with the tracking code.
  • Code used: Here is the HubSpot embed code we are attempting to implement:Start of HubSpot Embed Code --> <script type="text/javascript" id="hs-script-loader" async defer src="//js-eu1.hs-scripts.com/xxxxxxxx.js"></script> 

    Our main goal is to establish the connection properly so that we can start receiving data from the website into HubSpot. Has anyone experienced similar issues or does anyone have suggestions on how to resolve this? Any guidance on troubleshooting or modifying the implementation would be greatly appreciated.

     

0 Upvotes
1 Reply 1
HMir
Member

Hubspot tracking code


@CNM wrote:

We're currently facing a technical challenge and would appreciate any insights or solutions. Our client's website experiences (stripweb.be) stops loading whenever we activate the HubSpot tracking code through Google Tag Manager. Here’s the situation:

  • Issue: The website loads slowly and blocks specifically when the HubSpot tracking code is enabled.
  • Website setup: The site is built on a custom-made system and has functioned without issues until this problem began a month after initial setup.
  • Developer's Input: Our developer suggests that the crash may be due to the heavy load caused by numerous active fields used as filters in an e-commerce webshop. This load is conflicting with the tracking code.
  • Code used: Here is the HubSpot embed code we are attempting to implement:Start of HubSpot Embed Code --> <script type="text/javascript" id="hs-script-loader" async defer src="//js-eu1.hs-scripts.com/xxxxxxxx.js"></script> 

    Our main goal is to establish the connection properly so that we can start receiving data from the website into HubSpot. Has anyone experienced similar issues or does anyone have suggestions on how to resolve this? Any guidance on troubleshooting or modifying the implementation would be greatly appreciated.

     


If there are other tracking scripts running on the website, temporarily disable them one by one to see if the HubSpot code conflicts with any specific script. This will help narrow down the source of the problem.
Analyze the website's performance using browser developer tools (e.g., Chrome DevTools, Firefox DevTools). Look for any errors or performance bottlenecks specifically when the HubSpot code is enabled. This can pinpoint if the script itself is causing a heavy load.

0 Upvotes